zoukankan      html  css  js  c++  java
  • POJ3660 Cow Contest floyd传递闭包

    Description

    N (1 ≤ N ≤ 100) cows, conveniently numbered 1..N, are participating in a programming contest. As we all know, some cows code better than others. Each cow has a certain constant skill rating that is unique among the competitors.

    The contest is conducted in several head-to-head rounds, each between two cows. If cow A has a greater skill level than cow B (1 ≤ A ≤ N; 1 ≤ B ≤ NA ≠ B), then cow A will always beat cow B.

    Farmer John is trying to rank the cows by skill level. Given a list the results of M (1 ≤ M ≤ 4,500) two-cow rounds, determine the number of cows whose ranks can be precisely determined from the results. It is guaranteed that the results of the rounds will not be contradictory.

    Input

    * Line 1: Two space-separated integers: N and M
    * Lines 2..M+1: Each line contains two space-separated integers that describe the competitors and results (the first integer, A, is the winner) of a single round of competition: A and B

    Output

    * Line 1: A single integer representing the number of cows whose ranks can be determined

    Sample
    Sample Input
    
    5 5
    4 3
    4 2
    3 2
    1 2
    2 5
    Sample Output
    
    2

    题意:

      有n头牛比赛,m种比赛结果,最后问你一共有多少头牛的排名被确定了,其中如果a战胜b,b战胜c,则也可以说a战胜c,即可以传递胜负。求能确定排名的牛的数目。

    思路:

      如果一头牛被x头牛打败,打败y头牛,且x+y=n-1,则我们容易知道这头牛的排名就被确定了,所以我们只要将任何两头牛的胜负关系确定了,在遍历所有牛判断一下是否满足x+y=n-1,将满足这个条件的牛数目加起来就是所求解。如果出度+入度=顶点数-1,则能够确定其编号。

    代码:

    #include<stdio.h>
    #include<iostream>
    #include<algorithm>
    #include<cstring>
    using namespace std;
    int map[110][110];
    int n,m;
    void floyd()
    {
        for(int k=1;k<=n;k++)
            for(int i=1;i<=n;i++)
                for(int j=1;j<=n;j++)
                    if(map[i][k]==1&&map[k][j]==1)//关系传递
                        map[i][j]=1;
    }
    int main()
    {
        cin>>n>>m;
        memset(map,0,sizeof(map));
        for(int i=0;i<m;i++)
        {
            int a,b;
            cin>>a>>b;
            map[a][b]=1;//单向边
        }
        floyd();
        int ans=0;
        for(int i=1;i<=n;i++)
        {
            int sum=0;
            for(int j=1;j<=n;j++)
            {
                if((map[i][j]==1||map[j][i]==1)&&i!=j)
                    sum++;//计算出度和入度
            }
            if(sum==n-1)
                ans++;
        }
        cout<<ans;
    }
  • 相关阅读:
    URI 和 URL
    TCP/IP协议
    TCP/IP 通信传输流
    Python 之 函数可变参数和关键字参数
    Python 之装饰器decorator
    Python 之进程
    Android
    Redis持久化(persistence)
    python正则表达式
    selenium+python定位iframe元素
  • 原文地址:https://www.cnblogs.com/aiguona/p/7240491.html
Copyright © 2011-2022 走看看