zoukankan      html  css  js  c++  java
  • POJ3280--Cheapest Palindrome(动态规划)

    Keeping track of all the cows can be a tricky task so Farmer John has installed a system to automate it. He has installed on each cow an electronic ID tag that the system will read as the cows pass by a scanner. Each ID tag's contents are currently a single string with length M (1 ≤ M ≤ 2,000) characters drawn from an alphabet of N (1 ≤ N ≤ 26) different symbols (namely, the lower-case roman alphabet).

    Cows, being the mischievous creatures they are, sometimes try to spoof the system by walking backwards. While a cow whose ID is "abcba" would read the same no matter which direction the she walks, a cow with the ID "abcb" can potentially register as two different IDs ("abcb" and "bcba").

    FJ would like to change the cows's ID tags so they read the same no matter which direction the cow walks by. For example, "abcb" can be changed by adding "a" at the end to form "abcba" so that the ID is palindromic (reads the same forwards and backwards). Some other ways to change the ID to be palindromic are include adding the three letters "bcb" to the begining to yield the ID "bcbabcb" or removing the letter "a" to yield the ID "bcb". One can add or remove characters at any location in the string yielding a string longer or shorter than the original string.

    Unfortunately as the ID tags are electronic, each character insertion or deletion has a cost (0 ≤ cost ≤ 10,000) which varies depending on exactly which character value to be added or deleted. Given the content of a cow's ID tag and the cost of inserting or deleting each of the alphabet's characters, find the minimum cost to change the ID tag so it satisfies FJ's requirements. An empty ID tag is considered to satisfy the requirements of reading the same forward and backward. Only letters with associated costs can be added to a string.

    Input

    Line 1: Two space-separated integers: N and M 
    Line 2: This line contains exactly M characters which constitute the initial ID string 
    Lines 3.. N+2: Each line contains three space-separated entities: a character of the input alphabet and two integers which are respectively the cost of adding and deleting that character.

    Output

    Line 1: A single line with a single integer that is the minimum cost to change the given name tag.

    Sample Input

    3 4
    abcb
    a 1000 1100
    b 350 700
    c 200 800

    Sample Output

    900



    dp[i][j]表示区间[i,j],变成回文字符串的最小代价
    递推式思路:
      区间[i][j]可以由[i+1][j]或者[i][j-1] 并且加上对于字符i或者j的操作最小代价(删除,添加的最小值)
      为什么是删除添加的最小值呢?是因为,对于[i+1][j]表示的是这个区间为回文字符串的操作代价,有加上了个i字符,为了新的区间继续为回文字符串,所以需要再在末尾加上一个i,或者删除在首部加上的i
      因为从i+1推断出i所以要采用自底向上
    #include<iostream>
    #include<algorithm>
    #include<string>
    using namespace std;
    int dp[2005][2005];
    int op[26];
    int main(){
        int n,m;
        cin>>n>>m;
        string s;
        cin>>s;
        for(int i=0;i<n;i++){
            char c;
            int a,b;
            cin>>c>>a>>b;
            op[c-'a']=min(a,b);
        }
        for(int i=m-1;i>=0;i--){
            for(int j=i+1;j<m;j++){
                dp[i][j]=min(dp[i+1][j]+op[s[i]-'a'],dp[i][j-1]+op[s[j]-'a']);
                if(s[i]==s[j])
                    dp[i][j]=min(dp[i][j],dp[i+1][j-1]);
            }
        }
        cout<<dp[0][m-1]<<endl;
        return 0;
    } 

    ---恢复内容结束---

  • 相关阅读:
    团队开发冲刺日(十三)
    第十周总结
    团队开发冲刺日(十二)
    团队开发冲刺日(十一)
    团队开发冲刺日(十)
    团队开发冲刺日(九)
    团队开发冲刺日(八)
    团队开发冲刺日(七)
    团队开发冲刺日(六)
    课后作业1
  • 原文地址:https://www.cnblogs.com/albert67/p/10318649.html
Copyright © 2011-2022 走看看