zoukankan      html  css  js  c++  java
  • hdu Can you solve this equation?

    Can you solve this equation?

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 412    Accepted Submission(s): 237
     
    Problem Description
    Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100; Now please try your lucky.
     
    Input
    The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);
     
    Output
                For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.
     
    Sample Input
    2
    100
    -4
     
    Sample Output
    1.6152
    No solution!
     
    Author
    Redow
     
     
    Recommend
    lcy

    分析:典型二分,注意eps取值要恰当

    #include<cmath>
    #include<cstdio>
    #define eps 1e-8
    double fun(double x)
    {
        return 8*x*x*x*x + 7*x*x*x + 2*x*x + 3*x + 6;
    }
    int main()
    {
        double y,a,b,m,d;
        int T;
        scanf("%d",&T);
        while(T--)
        {
            scanf("%lf",&y);
            if(y<6 || y>807020306)
            {
                printf("No solution!\n");
                continue;
            }
            a=0.0;
            b=100.0;
            while(b-a>eps)
            {
                m=(a+b)/2;
                if(fun(m)<y)
                                a=m;
                            else
                                b=m;
            }
            printf("%.4f\n",a);
        }
        return 0;
    }
  • 相关阅读:
    Running APP 使用说明
    Android 控件八 WebView 控件
    Android 控件七 ImageView 控件
    Android 控件六 CheckBox 控件
    Android 控件五 RadioButton 控件
    Android 控件四 EditText 控件
    Android 控件三 TextView 控件实现 Button
    Android 控件二 Button
    Android 基础控件演示实例
    Android 控件一 TextView
  • 原文地址:https://www.cnblogs.com/baidongtan/p/2666047.html
Copyright © 2011-2022 走看看