zoukankan      html  css  js  c++  java
  • hdoj:2069

    Coin Change

    Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 18271    Accepted Submission(s): 6291



    Problem Description
    Suppose there are 5 types of coins: 50-cent, 25-cent, 10-cent, 5-cent, and 1-cent. We want to make changes with these coins for a given amount of money.

    For example, if we have 11 cents, then we can make changes with one 10-cent coin and one 1-cent coin, or two 5-cent coins and one 1-cent coin, or one 5-cent coin and six 1-cent coins, or eleven 1-cent coins. So there are four ways of making changes for 11 cents with the above coins. Note that we count that there is one way of making change for zero cent.

    Write a program to find the total number of different ways of making changes for any amount of money in cents. Your program should be able to handle up to 100 coins.
     
     
    Input
    The input file contains any number of lines, each one consisting of a number ( ≤250 ) for the amount of money in cents.
     
     
    Output
    For each input line, output a line containing the number of different ways of making changes with the above 5 types of coins.
     
     
    Sample Input
    11 26
     
     
    Sample Output
    4 13

     

    找零钱问题,但是限制了一次找零的硬币数量

     

    下面就直接暴力了

    #include <iostream>
    
    using namespace std;
    
    const int Max = 251;
    const int a[] = {1,5,10,25,50};
    long dp[Max];
    
    
    
    void change()
    {
        dp[0] = 1;
        for (int m = 1; m <= Max; m++)
        {
            for (int i50 = 0; i50 <= m / 50; i50++)
            {
                for (int i25 = 0; i25 <= (m - i50 * 50) / 25; i25++)
                {
                    for (int i10 = 0; i10 <= (m - i50 * 50 - i25 * 25) / 10; i10++)
                    {
                        for (int i5 = 0; i5 <= (m - i50 * 50 - i25 * 25 - i10 * 10) / 5; i5++)
                        {
                            int i1 = m - i50 * 50 - i25 * 25 - i10 * 10 - i5 * 5;
                            if (i1 >= 0 && i1 + i5 + i10 + i25 + i50 <= 100)
                            {
                                dp[m]++;
                            }
                        }
                    }
                }
            }
        }
        
    }
    int main()
    {
        int money;
        change();
        while (cin >> money)
        {
            cout << dp[money] << endl;
        }
    }
  • 相关阅读:
    hadoop大数据平台架构之DKhadoop详解
    越狱设备看不到系统文件夹
    iOS开发 调试 网络限速
    关于OCMock的一些事儿
    Cannot proceed with delivery: an existing transporter instance is currently uploading this package
    windows安装nose
    IE6支持png半透明图片
    ie下web常见错误和差异及解决方案
    js,php下 css颜色加深、减淡,css颜色递进的方法
    html+css div百分百占满正行的两种方法
  • 原文地址:https://www.cnblogs.com/bbbblog/p/6057377.html
Copyright © 2011-2022 走看看