zoukankan      html  css  js  c++  java
  • 按顺序输出字符串问题

    问题:

    Input
     
    The input consists of one or more sets of strings, followed by a final line containing only the value 0. Each set starts with a line containing an integer, n, which is the number of strings in the set, followed by n strings, one per line, sorted in nondescending order by length. None of the strings contain spaces. There is at least one and no more than 15 strings per set. Each string is at most 25 characters long.
    Output
     
    For each input set print "SET n" on a line, where n starts at 1, followed by the output set as shown in the sample output.
    Sample Input
     
    7
    Bo
    Pat
    Jean
    Kevin
    Claude
    William
    Marybeth
    6
    Jim
    Ben
    Zoe
    Joey
    Frederick
    Annabelle
    5
    John
    Bill
    Fran
    Stan
    Cece
    0
    Sample Output
     
    SET 1
    Bo
    Jean
    Claude
    Marybeth
    William
    Kevin
    Pat
    SET 2
    Jim
    Zoe
    Frederick
    Annabelle
    Joey
    Ben
    SET 3
    John
    Fran
    Cece
    Stan
    Bill
     
    回答:
    #include <iostream>
    #include <string>
    using namespace std;
    int main()
    {
    int n, t = 0, i, j, k;
    string word1[16], word2[16];
    while(cin >> n && n){
       j = k = 0;
       for(i=0; i<n; i++)
        cin >> word1[i];
       for(i=0; i<n; i++)
      if(i%2==0){
      word2[j] = word1[i];
      j++;
      }
      else {
      word2[n-k-1] = word1[i];
      k++;
      }
       cout << "SET " << ++t << endl;
       for(i=0; i<n; i++)
        cout << word2[i] << endl;
    }
        return 0;
    }
  • 相关阅读:
    MyString
    Django疑难问题
    mysql 疑难问题-django
    python时间转换 ticks-FYI
    django建议入门-FYI
    Python风格规范-FYI
    scrum敏捷开发☞
    git基本命令
    centos下的安装mysql,jdk
    memcached for .net on windows
  • 原文地址:https://www.cnblogs.com/benchao/p/4496481.html
Copyright © 2011-2022 走看看