zoukankan      html  css  js  c++  java
  • C

    Description

    Consider a group of N students and P courses. Each student visits zero, one or more than one courses. Your task is to determine whether it is possible to form a committee of exactly P students that satisfies simultaneously the conditions: 

    . every student in the committee represents a different course (a student can represent a course if he/she visits that course) 

    . each course has a representative in the committee 

    Your program should read sets of data from a text file. The first line of the input file contains the number of the data sets. Each data set is presented in the following format: 

    P N 
    Count1 Student1 1 Student1 2 ... Student1 Count1 
    Count2 Student2 1 Student2 2 ... Student2 Count2 
    ...... 
    CountP StudentP 1 StudentP 2 ... StudentP CountP 

    The first line in each data set contains two positive integers separated by one blank: P (1 <= P <= 100) - the number of courses and N (1 <= N <= 300) - the number of students. The next P lines describe in sequence of the courses . from course 1 to course P, each line describing a course. The description of course i is a line that starts with an integer Count i (0 <= Count i <= N) representing the number of students visiting course i. Next, after a blank, you'll find the Count i students, visiting the course, each two consecutive separated by one blank. Students are numbered with the positive integers from 1 to N. 

    There are no blank lines between consecutive sets of data. Input data are correct. 

    The result of the program is on the standard output. For each input data set the program prints on a single line "YES" if it is possible to form a committee and "NO" otherwise. There should not be any leading blanks at the start of the line. 

    An example of program input and output:

    Input

    2
    3 3
    3 1 2 3
    2 1 2
    1 1
    3 3
    2 1 3
    2 1 3
    1 1

    Output

    YES
    NO 

    Sample Input

    2
    3 3
    3 1 2 3
    2 1 2
    1 1
    3 3
    2 1 3
    2 1 3
    1 1

    Sample Output

    YES
    NO 
    #include <iostream>
    #include <stdio.h>
    #include <string.h>
    #include <string>
    #include <vector>
    #include <algorithm>
    #include <map>
    #include <queue>
    #include <stack>
    #include <math.h>
    
    using namespace std;
    
    #define met(a, b) memset(a, b, sizeof(a))
    #define N 303
    #define INF 0x3f3f3f3f
    const int MOD = 1e9+7;
    
    typedef long long LL;
    
    int vis[N], used[N];///used[i]表示y集合中的点是否匹配;
    int G[N][N], p, n;
    
    bool Hungary(int u)
    {
        for(int i=1; i<=p; i++)
        {
            if(!vis[i] && G[u][i])
            {
                vis[i] = 1;
                if(!used[i] || Hungary(used[i]))
                {
                    used[i] = u;
                    return true;
                }
            }
        }
        return false;
    }
    
    int main()
    {
        int T;
        scanf("%d", &T);
        while(T--)
        {
            memset(G, 0, sizeof(G));
            scanf("%d%d", &p, &n);
            for(int i=1; i<=p; i++)
            {
                int cnt, x;
                scanf("%d", &cnt);
                for(int j=1; j<=cnt; j++)
                {
                    scanf("%d", &x);
                    G[x][i] = 1;
                }
            }
            memset(used, 0, sizeof(used));
            int ans = 0;
            for(int i=1;i<=n; i++)
            {
                memset(vis, 0, sizeof(vis));
                if(Hungary(i))
                    ans++;
            }
            if(ans == p)
                puts("YES");
            else
                puts("NO");
        }
        return 0;
    }
  • 相关阅读:
    查看索引执行次数
    解决TFS服务器重命名后,无法访问的问题
    C#匿名方法增加、删除委托
    Silverlight 4 正确设置 ScrollViewer让它更好的支持鼠标滚轮
    Win8 loading 动画 Silverlight版本
    Silverlight控件自适应利器UseLayoutRounding属性(解决自适应抖动问题)
    添加从Web下载的dll引用,VS提示错误
    IQueryable<T>获取查询计划(SQL)
    WinForm多线程+委托防止界面假死
    ASP.net(c#)生成条形码 code39条码生成方法
  • 原文地址:https://www.cnblogs.com/biu-biu-biu-/p/5741673.html
Copyright © 2011-2022 走看看