zoukankan      html  css  js  c++  java
  • hdu6195 cable cable cable

    cable cable cable

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 2084    Accepted Submission(s): 1348


    Problem Description
    Connecting the display screen and signal sources which produce different color signals by cables, then the display screen can show the color of the signal source.Notice that every signal source can only send signals to one display screen each time. 
    Now you have M display screens and K different signal sources(KM2321). Select K display screens from M display screens, how many cables are needed at least so that **any** K display screens you select can show exactly K different colors.
     

    Input
    Multiple cases (no more than 100), for each test case:
    there is one line contains two integers M and K.
     

    Output
    Output the minimum number of cables N.
     

    Sample Input
    3 2 20 15
     

    Sample Output
    4 90
    Hint
    As the picture is shown, when you select M1 and M2, M1 show the color of K1, and M2 show the color of K2. When you select M3 and M2, M2 show the color of K1 and M3 show the color of K2. When you select M1 and M3, M1 show the color of K1.
     

    Statistic | Submit | Clarifications | Back


    题意:给出m个显示屏和k个信号,要求任选k个显示屏都可以显示所有的信号

    思路:找规律

    #include <iostream>
    
    using namespace std;
    typedef long long ll;
    int main()
    {
       ll m,k;
       while(cin>>m>>k)
       {
    
    
       ll tmp=m-(k+1);
       cout<<k*2+tmp*k<<endl;
       }
        return 0;
    }



  • 相关阅读:
    在cmd中登录ftp服务器
    Is valid identifier?
    Hosting Your Own NuGet Feeds
    NuGet学习笔记
    软件版本的处理
    有些事明显对自己有益,为什么却无法去做?
    .net 程序员成长路线图?
    正确跑步姿势是怎样的?
    什么叫做内心强大?怎样变成一个内心强大的人?
    使用命令行复制目录
  • 原文地址:https://www.cnblogs.com/bryce1010/p/9387253.html
Copyright © 2011-2022 走看看