zoukankan      html  css  js  c++  java
  • (补题 杭电 1008)Elevator

    Elevator

    Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 30095 Accepted Submission(s): 16272

    Problem Description

    The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

    For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

    Input

    There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case is not to be processed.

    Output

    Print the total time on a single line for each test case.

    Sample Input

    1 2
    3 2 3 1 
    0
    

    Sample Output

    17
    41
    

    水题(话说有这么zz的电梯吗23333)

    代码样例

    #include <stdio.h>
    

    int main() {
    int t;
    while (scanf("%d",&t) != EOF,t != 0) {
    int time=0,temp=0;
    for(int i=0; i < t; i++) {
    int n;
    scanf("%d",&n);
    if(temp < n) {
    time=time+(n-temp)6;
    temp=n;
    }
    if(temp > n) {
    time=time+(temp-n)
    4;
    temp=n;
    }
    if(temp == n)
    time=time+5;
    }
    printf("%d ",time);
    }
    return 0;
    }

  • 相关阅读:
    HTML5 GeoLocation 地理定位
    HTML5 LocalStorage 本地存储
    JS-事件代理(委托)
    面向对象(封装、继承、多态)
    js图片预加载
    jQuery 事件
    svn无法验证
    Ext.data.Store(转)
    ExtJS实现Excel导出(转)
    <![CDATA[ ]]> 意思
  • 原文地址:https://www.cnblogs.com/cafu-chino/p/10060419.html
Copyright © 2011-2022 走看看