zoukankan      html  css  js  c++  java
  • PAT 甲级 1029 Median (25 分)(思维题,找两个队列的中位数,没想到)*

                                                         1029 Median (25 分)

     

    Given an increasing sequence S of N integers, the median is the number at the middle position. For example, the median of S1 = { 11, 12, 13, 14 } is 12, and the median of S2 = { 9, 10, 15, 16, 17 } is 15. The median of two sequences is defined to be the median of the nondecreasing sequence which contains all the elements of both sequences. For example, the median of S1 and S2 is 13.

    Given two increasing sequences of integers, you are asked to find their median.

    Input Specification:

    Each input file contains one test case. Each case occupies 2 lines, each gives the information of a sequence. For each sequence, the first positive integer N (≤) is the size of that sequence. Then N integers follow, separated by a space. It is guaranteed that all the integers are in the range of long int.

    Output Specification:

    For each test case you should output the median of the two given sequences in a line.

    Sample Input:

    4 11 12 13 14
    5 9 10 15 16 17
    

    Sample Output:

    13

    题意:

    给出两个已排序序列,求这两个序列合并后的中间数

    思路:

    开一个数组,在线处理第二个数组。 第一二个数组(下标从1开始)分别有n,m个元素,中间数在(n + m + 1) / 2的位置。所以只要从小到大数到(n + m + 1) / 2的位置就行了~ count计总个数 ,给第一个数组设置指针i,每次从第二个数组中读入temp,检查第一个数组中前几个数是不是比temp小,小就count+1并判断是否到数了中间数,到了就输出。 如果数完比temp小的数还没到中间数,count+1,检查temp是不是中间数,是就输出。循环上述过程。如果第二个数组读取完了,还没数到中间数,说明中间数在剩下的第一个数组中,就在剩下的数组中数到中间数位置即可

    AC代码:

    #include<bits/stdc++.h>
    using namespace std;
    typedef long long ll;
    int a[200005];
    int main()
    {
        int n,m;
        cin>>n;
        for(int i=1;i<=n;i++)
        {
            cin>>a[i];
        }
        a[n + 1] = 0x7fffffff;
        cin>>m;
        int mid=(n+m+1)/2;
        int k=1,count=0;
        for(int i=1;i<=m;i++)
        {
            ll x;
            cin>>x;
            while(a[k]<x){
                count++;
                if(count==mid){
                    cout<<a[k];
                }
                k++;
            }
            count++;
            if(count==mid){
                cout<<x;
            }    
        }
        //如果第二个数组读取完了,还没数到中间数,
        //说明中间数在剩下的第一个数组中,就在剩下的数组中数到中间数位置即可
        while(count<=mid){
            count++;
            if(count==mid){
                cout<<a[k];
            }
            k++;        
        }
        return 0;
    }
    
     
  • 相关阅读:
    codeforces 733D
    HDU2647
    匈牙利算法 DFS模板(了解度+1)
    HDU1532 网络流:最大流之福德福克森算法
    mysql5 解压版 安装 建用户授权采坑
    Spring Boot 相关随笔
    Spring Boot 项目jar包 构建运行
    随笔小结
    war包 jar包理解(记录)
    vue axios异步请求及回调函数(前台)
  • 原文地址:https://www.cnblogs.com/caiyishuai/p/13270674.html
Copyright © 2011-2022 走看看