zoukankan      html  css  js  c++  java
  • 洛谷 P2904 [USACO08MAR]跨河River Crossing

    题目描述

    Farmer John is herding his N cows (1 <= N <= 2,500) across the expanses of his farm when he finds himself blocked by a river. A single raft is available for transportation.

    FJ knows that he must ride on the raft for all crossings and that that adding cows to the raft makes it traverse the river more slowly.

    When FJ is on the raft alone, it can cross the river in M minutes (1 <= M <= 1000). When the i cows are added, it takes M_i minutes (1 <= M_i <= 1000) longer to cross the river than with i-1 cows (i.e., total M+M_1 minutes with one cow, M+M_1+M_2 with two, etc.). Determine the minimum time it takes for Farmer John to get all of the cows across the river (including time returning to get more cows).

    Farmer John以及他的N(1 <= N <= 2,500)头奶牛打算过一条河,但他们所有的渡河工具,仅仅是一个木筏。 由于奶牛不会划船,在整个渡河过程中,FJ必须始终在木筏上。在这个基础上,木筏上的奶牛数目每增加1,FJ把木筏划到对岸就得花更多的时间。 当FJ一个人坐在木筏上,他把木筏划到对岸需要M(1 <= M <= 1000)分钟。当木筏搭载的奶牛数目从i-1增加到i时,FJ得多花M_i(1 <= M_i <= 1000)分钟才能把木筏划过河(也就是说,船上有1头奶牛时,FJ得花M+M_1分钟渡河;船上有2头奶牛时,时间就变成M+M_1+M_2分钟。后面的依此类推)。那么,FJ最少要花多少时间,才能把所有奶牛带到对岸呢?当然,这个时间得包括FJ一个人把木筏从对岸划回来接下一批的奶牛的时间。

    输入输出格式

    输入格式:

     

    • Line 1: Two space-separated integers: N and M

    • Lines 2..N+1: Line i+1 contains a single integer: M_i

     

    输出格式:

     

    • Line 1: The minimum time it takes for Farmer John to get all of the cows across the river.

     

    输入输出样例

    输入样例#1:
    5 10 
    3 
    4 
    6 
    100 
    1 
    
    输出样例#1:
    50 
    

    说明

    There are five cows. Farmer John takes 10 minutes to cross the river alone, 13 with one cow, 17 with two cows, 23 with three, 123 with four, and 124 with all five.

    Farmer John can first cross with three cows (23 minutes), then return (10 minutes), and then cross with the last two (17 minutes). 23+10+17 = 50 minutes total.

    #include<iostream>
    #include<cstdio>
    #include<cstring>
    #include<algorithm>
    using namespace std;
    int n,m,w[10000],f[100000];
    int main(){
        cin>>n>>m;
        w[0]=2*m;
        for(int i=1;i<=n;i++){
            int x;cin>>x;
            w[i]=x+w[i-1];
        }
        memset(f,0x3f,sizeof(f));
        f[0]=0;
        for(int i=1;i<=n;i++)
            for(int j=1;j<=i;j++)
                f[i]=min(f[i],f[i-j]+w[j]);
        cout<<f[n]-m;
    }
    细雨斜风作晓寒。淡烟疏柳媚晴滩。入淮清洛渐漫漫。 雪沫乳花浮午盏,蓼茸蒿笋试春盘。人间有味是清欢。
  • 相关阅读:
    Hadoop TextInputFormat源码分析
    Hadoop集群(第6期)_WordCount运行详解
    spring boot之从零开始开发自己的网站
    transfer learning
    深度学习理论
    CNN卷积可视化与反卷积
    resnet
    NLP资料
    close Spark Streaming gratefully
    CUDA
  • 原文地址:https://www.cnblogs.com/cangT-Tlan/p/7425436.html
Copyright © 2011-2022 走看看