zoukankan      html  css  js  c++  java
  • 栈 <stack> F

    I’m out of stories. For years I’ve been writing stories, some rather silly, just to make simple problems look difficult and complex problems look easy. But, alas, not for this one. 
    You’re given a non empty string made in its entirety from opening and closing braces. Your task is to find the minimum number of “operations” needed to make the string stable. The definition for being stable is as follows: 
    1. An empty string is stable. 
    2. If S is stable, then {S} is also stable. 
    3. If S and T are both stable, then ST (the concatenation of the two) is also stable. 
    All of these strings are stable: {}, {}{}, and {{}{}}; But none of these: }{, {{}{, nor {}{. 
    The only operation allowed on the string is to replace an opening brace with a closing brace, or visa-versa. 

    InputYour program will be tested on one or more data sets. Each data set is described on a single line. The line is a non-empty string of opening and closing braces and nothing else. No string has more than 2000 braces. All sequences are of even length.
    The last line of the input is made of one or more ’-’ (minus signs.) 

    OutputFor each test case, print the following line: 
    k. N 
    Where k is the test case number (starting at one,) and N is the minimum number of operations needed to convert the given string into a balanced one. 
    Note: There is a blank space before N. 
    Sample Input

    }{
    {}{}{}
    {{{}
    ---

    Sample Output

    1. 2
    2. 0
    3. 1
    通过代码

    #include<iostream>
    #include<stdio.h>
    #include<stack>
    #include<string.h>
    using namespace std;
    int main()
    {
    char ch[2000];
    stack<int>st;
    int t=0;
    while(++t)
    {
    gets(ch);
    int leng=strlen(ch);
    int jishu=0,sign=0;
    for(int i=0;i<leng;i++)
    {
    if(ch[i]=='-')
    {
    sign=1;
    break;
    }
    if(ch[i]=='{'&&st.empty())
    {
    st.push(1);
    continue;
    }
    if(ch[i]=='{'&&st.top()==1)
    {
    st.push(1);
    continue;
    }
    if(ch[i]=='}'&&st.empty())
    {
    st.push(1);
    jishu++;
    continue;
    }
    if(ch[i]=='}'&&st.top()==1)
    {
    st.pop();
    continue;
    }
    }
    if(sign==1) break;
    else
    {
    if(st.empty()) cout<<t<<". "<<jishu<<endl;
    else cout<<t<<". "<<jishu+st.size()/2<<endl;
    }
    jishu=0;                                //每次做完循环计数归0
    while(!st.empty()) st.pop();  //每次做完循环清空栈
    }
    }

  • 相关阅读:
    逻辑最复杂的MVVM模式实现
    剧本:博客园之天外飞仙
    本博客开始偏转方向,开始研究UDP在WCF下的实现
    Prism研究 目录
    Q & A category in Prism forums, with some answers and samples of mine.
    我眼中的SOA,以及在实际项目中的应用经验
    数据结构 C#描述 第三章 (更新)
    数据结构 C#描述 第四章
    数据结构 C#描述 第七章 (第一部分)
    数据结构 C#描述
  • 原文地址:https://www.cnblogs.com/carry-2017/p/7220710.html
Copyright © 2011-2022 走看看