zoukankan      html  css  js  c++  java
  • 栈 <stack> F

    I’m out of stories. For years I’ve been writing stories, some rather silly, just to make simple problems look difficult and complex problems look easy. But, alas, not for this one. 
    You’re given a non empty string made in its entirety from opening and closing braces. Your task is to find the minimum number of “operations” needed to make the string stable. The definition for being stable is as follows: 
    1. An empty string is stable. 
    2. If S is stable, then {S} is also stable. 
    3. If S and T are both stable, then ST (the concatenation of the two) is also stable. 
    All of these strings are stable: {}, {}{}, and {{}{}}; But none of these: }{, {{}{, nor {}{. 
    The only operation allowed on the string is to replace an opening brace with a closing brace, or visa-versa. 

    InputYour program will be tested on one or more data sets. Each data set is described on a single line. The line is a non-empty string of opening and closing braces and nothing else. No string has more than 2000 braces. All sequences are of even length.
    The last line of the input is made of one or more ’-’ (minus signs.) 

    OutputFor each test case, print the following line: 
    k. N 
    Where k is the test case number (starting at one,) and N is the minimum number of operations needed to convert the given string into a balanced one. 
    Note: There is a blank space before N. 
    Sample Input

    }{
    {}{}{}
    {{{}
    ---

    Sample Output

    1. 2
    2. 0
    3. 1
    通过代码

    #include<iostream>
    #include<stdio.h>
    #include<stack>
    #include<string.h>
    using namespace std;
    int main()
    {
    char ch[2000];
    stack<int>st;
    int t=0;
    while(++t)
    {
    gets(ch);
    int leng=strlen(ch);
    int jishu=0,sign=0;
    for(int i=0;i<leng;i++)
    {
    if(ch[i]=='-')
    {
    sign=1;
    break;
    }
    if(ch[i]=='{'&&st.empty())
    {
    st.push(1);
    continue;
    }
    if(ch[i]=='{'&&st.top()==1)
    {
    st.push(1);
    continue;
    }
    if(ch[i]=='}'&&st.empty())
    {
    st.push(1);
    jishu++;
    continue;
    }
    if(ch[i]=='}'&&st.top()==1)
    {
    st.pop();
    continue;
    }
    }
    if(sign==1) break;
    else
    {
    if(st.empty()) cout<<t<<". "<<jishu<<endl;
    else cout<<t<<". "<<jishu+st.size()/2<<endl;
    }
    jishu=0;                                //每次做完循环计数归0
    while(!st.empty()) st.pop();  //每次做完循环清空栈
    }
    }

  • 相关阅读:
    my read map subway / metro / map / ditie / gaotie / traffic / jiaotong
    hd printer lexmark / dazifuyin / dayin / fuyin
    软件应用程序的打包和部署
    99款高质量免费(X)HTML/CSS模板
    PetShop4.0的安装、设置、调试与体验(草稿)
    山塞一个PetShop(Task000)——架构
    如何用C#开发的计算器小软件
    DIV+CSS布局参考站点
    影响计算机性能的设置
    ASP.NET知识点:母版页的路径问题
  • 原文地址:https://www.cnblogs.com/carry-2017/p/7220710.html
Copyright © 2011-2022 走看看