zoukankan      html  css  js  c++  java
  • 1004 Counting Leaves (30 分)

    A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

    Input Specification:

    Each input file contains one test case. Each case starts with a line containing 0<N<100, the number of nodes in a tree, and M (<N), the number of non-leaf nodes. Then M lines follow, each in the format:

    ID K ID[1] ID[2] ... ID[K]

    where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 01.

    The input ends with N being 0. That case must NOT be processed.

    Output Specification:

    For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

    The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output 0 1 in a line.

    Sample Input:

    2 1
    01 1 02

    Sample Output:

    0 1

    Submit:

    #include <iostream>
    #include <vector>
    #include <algorithm>
    using namespace std;
    vector<int> v[100];
    int book[100], maxdepth = -1;
    void dfs(int index, int depth) {
        if(v[index].size() == 0) {
            book[depth]++;
            maxdepth = max(maxdepth, depth);
            return ;
        }
        for(int i = 0; i < v[index].size(); i++)
            dfs(v[index][i], depth + 1);
    }
    int main() {
        int n, m, k, node, c;
        scanf("%d %d", &n, &m);
        for(int i = 0; i < m; i++) {
            scanf("%d %d",&node, &k);
            for(int j = 0; j < k; j++) {
                scanf("%d", &c);
                v[node].push_back(c);
            }
        }
        dfs(1, 0);
        printf("%d", book[0]);
        for(int i = 1; i <= maxdepth; i++)
            printf(" %d", book[i]);
        return 0;
    }

    参考:

    柳婼-https://blog.csdn.net/liuchuo/article/details/54561626

    昵称五个字-https://blog.csdn.net/a617976080/article/details/89676670

  • 相关阅读:
    异常处理
    PAT——1048. 数字加密
    PAT——1047. 编程团体赛
    PAT——1046. 划拳
    PAT——1045. 快速排序(25)
    PAT——1044. 火星数字
    PAT——1043. 输出PATest
    PAT——1042. 字符统计
    PAT——1041. 考试座位号
    PAT——1040. 有几个PAT
  • 原文地址:https://www.cnblogs.com/cgy-home/p/15109883.html
Copyright © 2011-2022 走看看