zoukankan      html  css  js  c++  java
  • 1019. General Palindromic Number更新

    1019. General Palindromic Number (20)

    时间限制
    400 ms
    内存限制
    65536 kB
    代码长度限制
    16000 B
    判题程序
    Standard
    作者
    CHEN, Yue

    A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

    Although palindromic numbers are most often considered in the decimal system, the concept of palindromicity can be applied to the natural numbers in any numeral system. Consider a number N > 0 in base b >= 2, where it is written in standard notation with k+1 digits ai as the sum of (aibi) for i from 0 to k. Here, as usual, 0 <= ai < b for all i and ak is non-zero. Then N is palindromic if and only if ai = ak-i for all i. Zero is written 0 in any base and is also palindromic by definition.

    Given any non-negative decimal integer N and a base b, you are supposed to tell if N is a palindromic number in base b.

    Input Specification:

    Each input file contains one test case. Each case consists of two non-negative numbers N and b, where 0 <= N <= 109 is the decimal number and 2 <= b <= 109 is the base. The numbers are separated by a space.

    Output Specification:

    For each test case, first print in one line "Yes" if N is a palindromic number in base b, or "No" if not. Then in the next line, print N as the number in base b in the form "ak ak-1 ... a0". Notice that there must be no extra space at the end of output.

    Sample Input 1:
    27 2
    
    Sample Output 1:
    Yes
    1 1 0 1 1
    
    Sample Input 2:
    121 5
    
    Sample Output 2:
    No
    4 4 1
    import java.util.Scanner;
    
    public class Main {
    
    	public static void main(String[] args) {
    		Scanner in =new Scanner(System.in);
    		int n,b;
    		n=in.nextInt();
    		b=in.nextInt();
    		int flag=0;
    		String str = "";
    		if(n==0) {
    			System.out.println("Yes");
    			System.out.print("0");
    		}
    		else{
    			str=change(n,b);
    			for(int i=0;i<str.length()/2;i++){
    				//System.out.println(str.charAt(i)+" "+str.charAt(str.length()-i-1));
    				if(str.charAt(i)!=str.charAt(str.length()-i-1)){
    					flag=1;
    					break;
    				}
    			}
    		if(flag==1) System.out.println("No");
    		else System.out.println("Yes");
    		for(int i=str.length()-1;i>=0;i--){
    			if(i!=0)
    			System.out.printf("%d ",str.charAt(i)-'0');
    			else 
    			System.out.print(str.charAt(i));
    			}
    		}
    	}
    
    	private static String change(int n, int b) {
    		String s ="";
    		while(n>0){
    			s=s+n%b;
    			n=n/b;
    		}
    		return s;
    	}
    
    }
    

      结果:

    请教大佬之后发现,由于使用charat 所以在15 16 这样的用例显示会显示no 1 5造成错误

    import java.util.Scanner;
    
    public class Main {
    
        public static void main(String[] args) {
            Scanner in =new Scanner(System.in);
            int n,b;
            String[] strings;
            n=in.nextInt();
            b=in.nextInt();
            int flag=0;
            String str = "";
            if(n==0) {
                System.out.println("Yes");
                System.out.print("0");
            }
            else{
                str=change(n,b);
                strings = str.split("#");
                for(int i=0;i<strings.length/2;i++){
                    //System.out.println(str.charAt(i)+" "+str.charAt(str.length()-i-1));
                    if(!strings[i].equals(strings[strings.length-i-1])){
                        flag=1;
                        break;
                    }
                }
            if(flag==1) System.out.println("No");
            else System.out.println("Yes");
            for(int i=strings.length-1;i>=0;i--){
                if(i!=0)
                    System.out.printf("%s ",strings[i]);
                else 
                    System.out.print(strings[i]);
                }
            }
        }
    
        private static String change(int n, int b) {
            String s = "" + n % b;
            n /= b;
            while(n>0){
                s += "#" + n % b;
                n /= b;
            }
            return s;
        }
    
    }

    结果

    人生是如此的艰难,我还自带坑属性。。。。。。

  • 相关阅读:
    java语言体系的技术简介之JSP、Servlet、JDBC、JavaBean(Application)
    浅谈HTTP中Get与Post的区别
    浅谈HTTP中Get与Post的区别
    图文混排
    Algorithm: quick sort implemented in python 算法导论 快速排序
    algorithm: heap sort in python 算法导论 堆排序
    Leetcode OJ : Compare Version Numbers Python solution
    Python 同时for遍历多个列表
    Leetcode OJ : Repeated DNA Sequences hash python solution
    Leetcode OJ : Triangle 动态规划 python solution
  • 原文地址:https://www.cnblogs.com/chen20135517/p/7726204.html
Copyright © 2011-2022 走看看