zoukankan      html  css  js  c++  java
  • nyoj 364——田忌赛马——————【贪心】

    田忌赛马

    时间限制:3000 ms  |  内存限制:65535 KB
    难度:3
     
    描述
    Here is a famous story in Chinese history.

    "That was about 2300 years ago. General Tian Ji was a high official in the country Qi. He likes to play horse racing with the king and others."

    "Both of Tian and the king have three horses in different classes, namely, regular, plus, and super. The rule is to have three rounds in a match; each of the horses must be used in one round. The winner of a single round takes two hundred silver dollars from the loser."

    "Being the most powerful man in the country, the king has so nice horses that in each class his horse is better than Tian's. As a result, each time the king takes six hundred silver dollars from Tian."

    "Tian Ji was not happy about that, until he met Sun Bin, one of the most famous generals in Chinese history. Using a little trick due to Sun, Tian Ji brought home two hundred silver dollars and such a grace in the next match."

    "It was a rather simple trick. Using his regular class horse race against the super class from the king, they will certainly lose that round. But then his plus beat the king's regular, and his super beat the king's plus. What a simple trick. And how do you think of Tian Ji, the high ranked official in China?"

    Were Tian Ji lives in nowadays, he will certainly laugh at himself. Even more, were he sitting in the ACM contest right now, he may discover that the horse racing problem can be simply viewed as finding the maximum matching in a bipartite graph. Draw Tian's horses on one side, and the king's horses on the other. Whenever one of Tian's horses can beat one from the king, we draw an edge between them, meaning we wish to establish this pair. Then, the problem of winning as many rounds as possible is just to find the maximum matching in this graph. If there are ties, the problem becomes more complicated, he needs to assign weights 0, 1, or -1 to all the possible edges, and find a maximum weighted perfect matching...

    However, the horse racing problem is a very special case of bipartite matching. The graph is decided by the speed of the horses --- a vertex of higher speed always beat a vertex of lower speed. In this case, the weighted bipartite matching algorithm is a too advanced tool to deal with the problem.

    In this problem, you are asked to write a program to solve this special case of matching problem.
     
    输入
    The input consists of many test cases. Each case starts with a positive integer n (n <= 1000) on the first line, which is the number of horses on each side. The next n integers on the second line are the speeds of Tian’s horses. Then the next n integers on the third line are the speeds of the king’s horses.
    输出
    For each input case, output a line containing a single number, which is the maximum money Tian Ji will get, in silver dollars.

    样例输入
    3
    92 83 71
    95 87 74
    2
    20 20
    20 20
    2
    20 19
    22 18
    样例输出
    200
    0
    0


    题目大意:给田忌n匹马,给国王n匹马,输一轮减少200块钱,赢一轮增加200块钱,平局不奖惩。问最后最多能得到多少钱。


    解题思路:如果田忌的慢马能赢国王的,就赢。如果比国王的慢,就拉国王的最快的马比,反正输,不如输的更有价值,为后边的马减小阻力。如果慢马一样快,首先看田忌的最快的马是不是比国王最快的马快,如果是就先让最快的马赢一局。如果不是,就让田忌的最慢的马跟国王的最快的马比较是不是相等,如果不是,那么就输一局;如果是,就让田忌最慢的马跟国王最快的马平局。

    #include<bits/stdc++.h>
    using namespace std;
    int tj[1100],king[1100];
    int main(){
        int t,i,j,k,tmp,sum,cnt,n,m,tslow,tfast,kslow,kfast;
        while(scanf("%d",&n)!=EOF){
            memset(tj,0,sizeof(tj));
            memset(king,0,sizeof(king));
            for(i=0;i<n;i++){
                scanf("%d",&tj[i]);
            }
            for(i=0;i<n;i++){
                scanf("%d",&king[i]);
            }
            sort(tj,tj+n);
            sort(king,king+n);
            tslow=kslow=0;
            tfast=kfast=n-1;
            m=k=0;
            while(m<n){
                if(tj[tslow]>king[kslow]){  //田忌慢马比国王慢马快
                    tslow++;
                    kslow++;
                    k++;
                }else if(tj[tslow]<king[kslow]){//田忌慢马比国王慢马慢
                    tslow++;
                    kfast--;
                    k--;
                }else{//两人慢马同速
                    if(tj[tfast]>king[kfast]){//田忌快马比国王快马快
                        tfast--;
                        kfast--;
                        k++;
                    }else {//田忌快马慢于或等于国王快马
                        if(tj[tslow]<king[kfast]){//田忌慢马比国王快马慢
                            kfast--;
                            tslow++;
                            k--;
                        }else if(tj[tslow]==king[kfast]){//田忌慢马等于国王快马
                            tslow++;
                            kfast--;
                        }
                    }
                }
                m++;
            }
            cout<<k*200<<endl;
        }
        return 0;
    }
    /*
    5
    8 6 5 1 3   
    9 7 6 4 2   
    */
    

      




  • 相关阅读:
    springBoot异常处理
    webSocket
    Java正则
    String.format
    JSTL-taglib
    http meta
    chrome 常用插件下载安装
    mysql 命令行个性化设置
    Entity Framework Code First
    SignalR Connection has not been fully initialized
  • 原文地址:https://www.cnblogs.com/chengsheng/p/4630883.html
Copyright © 2011-2022 走看看