zoukankan      html  css  js  c++  java
  • HDU 2594 Simpsons’ Hidden Talents

    Simpsons’ Hidden Talents

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 5061    Accepted Submission(s): 1845



    Problem Description
    Homer: Marge, I just figured out a way to discover some of the talents we weren’t aware we had.
    Marge: Yeah, what is it?
    Homer: Take me for example. I want to find out if I have a talent in politics, OK?
    Marge: OK.
    Homer: So I take some politician’s name, say Clinton, and try to find the length of the longest prefix
    in Clinton’s name that is a suffix in my name. That’s how close I am to being a politician like Clinton
    Marge: Why on earth choose the longest prefix that is a suffix???
    Homer: Well, our talents are deeply hidden within ourselves, Marge.
    Marge: So how close are you?
    Homer: 0!
    Marge: I’m not surprised.
    Homer: But you know, you must have some real math talent hidden deep in you.
    Marge: How come?
    Homer: Riemann and Marjorie gives 3!!!
    Marge: Who the heck is Riemann?
    Homer: Never mind.
    Write a program that, when given strings s1 and s2, finds the longest prefix of s1 that is a suffix of s2.
     

    Input
    Input consists of two lines. The first line contains s1 and the second line contains s2. You may assume all letters are in lowercase.
     

    Output
    Output consists of a single line that contains the longest string that is a prefix of s1 and a suffix of s2, followed by the length of that prefix. If the longest such string is the empty string, then the output should be 0.
    The lengths of s1 and s2 will be at most 50000.
     

    Sample Input
    clinton homer riemann marjorie
     

    Sample Output
    0 rie 3
     
    题意是求最长主串的前缀与模式串后缀匹配。
    这种,只要连接后,便可利用KMP的功能,来实现找到其前缀后缀的最大匹配。
    注意中间需要一个不会出现的字符进行隔开,以防出现自我匹配的情况。

    代码如下;
    /*************************************************************************
    	> File Name: Simpsons_Hidden_Talents.cpp
    	> Author: Zhanghaoran
    	> Mail: chilumanxi@xiyoulinux.org
    	> Created Time: Wed 02 Dec 2015 05:14:12 PM CST
     ************************************************************************/
    
    #include <iostream>
    #include <algorithm>
    #include <cstring>
    #include <cstdio>
    #include <cstdlib>
    
    using namespace std;
    
    void preKMP(char x[], int m, int kmpnext[]){
        int i, j;
        i = 0;
        j = kmpnext[0] = -1;
        while(i < m){
            while(j != -1 && x[i] != x[j])
                j = kmpnext[j];
            if(x[++ i] == x[++ j])
                kmpnext[i] = kmpnext[j];
            else 
                kmpnext[i] = j;
        }
    }
    
    int nexti[100010];
    
    int main(void){
        char str1[100010];
        char str2[50010];
        while(~(scanf("%s%s", str1, str2))){
            int temp1 = strlen(str1);
            str1[temp1] = '&';
            str1[temp1 + 1] = '';
            strcat(str1, str2);
            int temp = strlen(str1);
            preKMP(str1, temp, nexti);
            if(nexti[temp]){
                for(int i  = 0; i < nexti[temp]; i ++){
                    printf("%c", str1[i]);
                }
                cout << " ";
                cout << nexti[temp] << endl;
            }
            else
                cout << nexti[temp] << endl;
        }
    }


  • 相关阅读:
    jsp学习笔记(一)
    20170215学习计划
    腾讯云CVM使用记录--使用root权限
    转:ASP.NET MVC3 Model验证总结
    ASP.NET MVC3更新出错:ObjectStateManager中已存在具有同一键的对象
    c#中如何将一个string数组转换为int数组
    转:自定义ASP.NET MVC Html辅助方法
    转:ASP.NET MVC扩展之HtmlHelper辅助方法
    自己用的一个ASP.Net MVC分页拿出来分享下(转)
    MVC分页控件之二,为IQueryable定义一个扩展方法,直接反回PagedList<T>结果集(转)
  • 原文地址:https://www.cnblogs.com/chilumanxi/p/5136047.html
Copyright © 2011-2022 走看看