zoukankan      html  css  js  c++  java
  • A POJ1611

    The Suspects
    Time Limit:1000MS     Memory Limit:20000KB     64bit IO Format:%I64d & %I64u
    Submit

    Status
    Description
    Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.
    In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).
    Once a member in a group is a suspect, all members in the group are suspects.
    However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.
    Input
    The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.
    A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.
    Output
    For each case, output the number of suspects in one line.
    Sample Input
    100 4
    2 1 2
    5 10 13 11 12 14
    2 0 1
    2 99 2
    200 2
    1 5
    5 1 2 3 4 5
    1 0
    0 0
    Sample Output
    4
    1
    1
    <span style="color:#3333ff;">/*
    ***************************************************
           author   :   Grant Yuan
           time     :   2014.7.24
           algorithm:   并查集
    
    ***************************************************
    */
    
    #include<iostream>
    #include<cstdio>
    #include<cstring>
    #include<cstdlib>
    #include<algorithm>
    #define MAX 30001
    
    using namespace std;
    
    int par[MAX];
    int high[MAX];
    int n,m,k,t0,t;
    
    void init()
    {
        for(int i=0;i<n;i++)
        {
            par[i]=i;
            high[i]=0;
        }
    }
    
    
    int find(int x)
    {
        if(par[x]==x) return x;
        else
             return par[x]=find(par[x]);
    
    }
    
    
    void unite(int x,int y)
    {
        x=find(x);
        y=find(y);
        if(x==y) return;
    
         if(high[x]<high[y]){
            par[x]=y;
         }
         else{
            par[y]=x;
            if(high[x]==high[y]) high[x]++;
         }
    }
    
    bool same(int x,int y)
    {
        return find(x)==find(y);
    }
    
    int main()
    {   int f1,f2,ans;;
    
        while(~scanf("%d%d",&n,&m)&&m+n){
            ans=0;
            init();
            if(m==0)
                 cout<<"1"<<endl;
    
            else{
            for(int i=0;i<m;i++)
            {
                scanf("%d%d",&k,&t0);
                for(int i=1;i<k;i++)
                {
                    scanf("%d",&t);
                    f1=find(t0);
                    f2=find(t);
                    unite(f1,f2);
                }
            }
    
            for(int i=0;i<n;i++)
            {
                    if(find(0)==find(i))
                   ans++;
            }
            cout<<ans<<endl;}
        }
        return 0;
    }
    </span>

  • 相关阅读:
    jdbc连接数据库(mysql,sqlserver,oracle)
    简单粗暴将sqlserver表以及数据迁移到oracle
    LXD 2.0 系列(五):镜像管理
    LXD 2.0 系列(十二):调试,及给 LXD 做贡献
    LXD 2.0 系列(七):LXD 中的 Docker
    LXD 2.0 系列(四):资源控制
    LXD 2.0 系列(三):你的第一个 LXD 容器
    LXD 2.0 系列(二):安装与配置
    LXD 2.0 系列(一):LXD 入门
    Debian-linux 网卡配置
  • 原文地址:https://www.cnblogs.com/codeyuan/p/4254487.html
Copyright © 2011-2022 走看看