zoukankan      html  css  js  c++  java
  • 括号配对问题

    括号配对问题

    时间限制:3000 ms  |  内存限制:65535 KB
    难度:3
    描述
    现在,有一行括号序列,请你检查这行括号是否配对。
    输入
    第一行输入一个数N(0<N<=100),表示有N组测试数据。后面的N行输入多组输入数据,每组输入数据都是一个字符串S(S的长度小于10000,且S不是空串),测试数据组数少于5组。数据保证S中只含有"[","]","(",")"四种字符
    输出
    每组输入数据的输出占一行,如果该字符串中所含的括号是配对的,则输出Yes,如果不配对则输出No
    样例输入
    3
    [(])
    (])
    ([[]()])
    样例输出
    No
    No
    Yes
    #include <iostream>
    #include <cstdio>
    using namespace std;
    int main()
    {
    	int n,top,j;
    	char str[10000],stack[5000];
    	cin>>n;
    	while(n--)
    	{
    		scanf("%s",str);
    		if(str[0]==')'||str[0]==']') stack[0]='1';
    		else
    		{
    			for(top=0,j=0;str[j]!='\0';j++)
    			{
    				if(str[j]=='('||str[j]=='[')
    				{
    					stack[top]=str[j];
    					top++;
    				}
    				else if(str[j]==']')
    				{
    					if(stack[top-1]!='[')
    					{
    						stack[0]='1';
    						break;
    					}
    					else
    					{
    						stack[top-1]='0';
    						top--;;
    					}
    				}
    				else if(str[j]==')')
    				{
    					if(stack[top-1]!='(')
    					{
    						stack[0]='1';
    						break;
    					}
    					else
    					{
    						stack[top-1]='0';
    						top--;
    					}
    				}
    			}
    		}
    		printf(stack[0]=='0'?"Yes\n":"No\n");
    	}
    	return 0;
    }
    


  • 相关阅读:
    go语言的垮平台编译
    vscode使用技巧
    集合
    泛型
    异常
    Java垃圾回收机制
    java学习笔记9.20
    java变量类型
    目前的学习计划
    离第一篇博客三天
  • 原文地址:https://www.cnblogs.com/cszlg/p/2910537.html
Copyright © 2011-2022 走看看