zoukankan      html  css  js  c++  java
  • hdu 1045 Fire Net dfs深搜或者二分匹配

    Fire Net
    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 12961    Accepted Submission(s): 7865

    Problem Description


    Suppose that we have a square city with straight streets. A map of a city is a square board with n rows and n columns, each representing a street or a piece of wall. 


    A blockhouse is a small castle that has four openings through which to shoot. The four openings are facing North, East, South, and West, respectively. There will be one machine gun shooting through each opening. 


    Here we assume that a bullet is so powerful that it can run across any distance and destroy a blockhouse on its way. On the other hand, a wall is so strongly built that can stop the bullets. 


    The goal is to place as many blockhouses in a city as possible so that no two can destroy each other. A configuration of blockhouses is legal provided that no two blockhouses are on the same horizontal row or vertical column in a map unless there is at least one wall separating them. In this problem we will consider small square cities (at most 4x4) that contain walls through which bullets cannot run through. 


    The following image shows five pictures of the same board. The first picture is the empty board, the second and third pictures show legal configurations, and the fourth and fifth pictures show illegal configurations. For this board, the maximum number of blockhouses in a legal configuration is 5; the second picture shows one way to do it, but there are several other ways. 




    Your task is to write a program that, given a description of a map, calculates the maximum number of blockhouses that can be placed in the city in a legal configuration. 

    Input

    The input file contains one or more map descriptions, followed by a line containing the number 0 that signals the end of the file. Each map description begins with a line containing a positive integer n that is the size of the city; n will be at most 4. The next n lines each describe one row of the map, with a '.' indicating an open space and an uppercase 'X' indicating a wall. There are no spaces in the input file. 

    Output

    For each test case, output one line containing the maximum number of blockhouses that can be placed in the city in a legal configuration.


    Sample Input

    4
    .X..
    ....
    XX..
    ....
    2
    XX
    .X
    3
    .X.
    X.X
    .X.
    3
    ...
    .XX
    .XX
    4
    ....
    ....
    ....
    ....
    0

    Sample Output

    5
    1
    5
    2
    4

    题意:每行每列不能有两个除非两个之间有一道墙挡着。

    思路:找的是符合要求的最多的方法。用dfs(深搜)

    #include<stdio.h>
    #include<string.h>
    #include<string>
    #include<iostream>
    #include<algorithm>
    using namespace std;
    const int maxn=10;
    int un,vn;
    int ans;
    int g[maxn][maxn];
    int vis[maxn][maxn];
    int l[maxn];
    void dfs(int x,int y,int z,int flag)
    {
        //cout<<x<<y<<z<<endl;
        ans=max(ans,z);
        if(x>=vn||y>=vn)return ;
    
        for(int i=y; i<vn; i++)
        {
            if(!g[x][i])
            {
                flag=0;
                l[i]=0;
                continue;
            }
            else
            {
                if(l[i]==0&&flag==0)
                {
                    //flag=1;
                    l[i]=1;
                    dfs(x+1,0,z+1,0);
                    dfs(x,i+1,z+1,1);
                    l[i]=0;
                }
            }
        }
        dfs(x+1,0,z,0);
        return ;
    }
    int main()
    {
        while(cin>>vn)
        {
            if(vn==0)break;
            un=vn;
            string s;
            memset(g,0,sizeof(g));
            memset(vis,0,sizeof(vis));
            memset(l,0,sizeof(l));
            for(int i=0; i<vn; i++)
            {
                cin>>s;
                for(int j=0; j<vn; j++)
                {
                    if(s[j]=='.')
                        g[i][j]=1;
                    else
                        g[i][j]=0;
                }
            }
            ans=0;
            dfs(0,0,0,0);
            cout<<ans<<endl;
        }
    }


    二分匹配:

    把可以放的点按照规则找出来。放到新的图中然后用匈牙利算法找最大匹配。

    #include<stdio.h>
    #include<iostream>
    #include<algorithm>
    #include<string.h>
    #include<string>
    using namespace std;
    const int maxn=10;
    int un,vn;
    int g[maxn][maxn];
    int a[maxn][maxn];
    int b[maxn][maxn];
    int linker[maxn];
    bool used[maxn];
    bool dfs(int u)
    {
        for(int v=1; v<=vn; v++)
        {
            if(g[u][v]&&!used[v])
            {
                used[v]=true;
                if(linker[v]==-1||dfs(linker[v]))
                {
                    linker[v]=u;
                    return true;
                }
            }
        }
        return false;
    }
    int hungary()
    {
        int res=0;
        memset(linker,-1,sizeof(linker));
        for(int u=1; u<=un; u++)
        {
            memset(used,false,sizeof(used));
            if(dfs(u))res++;
        }
        return res;
    }
    int main()
    {
        string s[10];
        int n;
        while(cin>>n)
        {
            if(n==0)break;
            un=0;
            vn=0;
            memset(a,0,sizeof(a));
            memset(b,0,sizeof(b));
            memset(g,0,sizeof(g));
            for(int i=0; i<10; i++)
                s[i].clear();
            for(int i=0; i<n; i++)
            {
                cin>>s[i];
            }
            for(int i=0; i<n; i++)
            {
                int flag=0;
                for(int j=0; j<n; j++)
                {
                    if(s[i][j]=='.'&&flag==0)
                    {
                        un++;
    
                        a[i][j]=un;
                        flag=1;
                    }
                    if(s[i][j]=='X')
                        flag=0;
                    if(s[i][j]=='.'&&flag)
                        a[i][j]=un;
                }
            }
            for(int i=0; i<n; i++)
            {
                int flag=0;
                for(int j=0; j<n; j++)
                {
                    if(s[j][i]=='.'&&flag==0)
                    {
                        vn++;
                        b[j][i]=vn;
                        flag=1;
                    }
                    if(s[j][i]=='X')
                    {
                        flag=0;
                    }
                    if(s[j][i]=='.'&&flag)
                    {
                        b[j][i]=vn;
                    }
                }
            }
            for(int i=0; i<n; i++)
                for(int j=0; j<n; j++)
                {
                    g[a[i][j]][b[i][j]]=1;
                }
    
            cout<<hungary()<<endl;
        }
    }




     

  • 相关阅读:
    初学c课程笔记整理7-->>二维数组、字符串、指针
    初学c课程笔记整理6-->>数组
    ipad上自定义view的旋转适配
    苹果mac电脑中brew的安装使用及卸载详细教程
    Apple、Google、Microsoft的用户体验设计原则
    iOS图片拉伸技巧
    子网掩码解析【转载】
    Ios8,Xcode6下 设置Launch Image 启动图片
    ios8 设置单元格分割线无效
    简述UIScrollView的属性和用法
  • 原文地址:https://www.cnblogs.com/da-mei/p/9053306.html
Copyright © 2011-2022 走看看