zoukankan      html  css  js  c++  java
  • 1112 Stucked Keyboard (20 分)

    On a broken keyboard, some of the keys are always stucked. So when you type some sentences, the characters corresponding to those keys will appear repeatedly on screen for k times.

    Now given a resulting string on screen, you are supposed to list all the possible stucked keys, and the original string.

    Notice that there might be some characters that are typed repeatedly. The stucked key will always repeat output for a fixed k times whenever it is pressed. For example, when k=3, from the string thiiis iiisss a teeeeeest we know that the keys i and e might be stucked, but s is not even though it appears repeatedly sometimes. The original string could be this isss a teest.

    Input Specification:

    Each input file contains one test case. For each case, the 1st line gives a positive integer k (1) which is the output repeating times of a stucked key. The 2nd line contains the resulting string on screen, which consists of no more than 1000 characters from {a-z}, {0-9} and _. It is guaranteed that the string is non-empty.

    Output Specification:

    For each test case, print in one line the possible stucked keys, in the order of being detected. Make sure that each key is printed once only. Then in the next line print the original string. It is guaranteed that there is at least one stucked key.

    Sample Input:

    3
    caseee1__thiiis_iiisss_a_teeeeeest
     

    Sample Output:

    ei
    case1__this_isss_a_teest


    20分的题都能出的这么复杂,姥姥厉害啊!
    #include<bits/stdc++.h>
    using namespace std;
    const int maxn=100010;
    map<char,int> mp;
    
    int main(){
        int k;
        vector<char> chucked(128,-1);
        vector<char> visited(128);
        cin>>k;
        string str;
        cin>>str;
        int i=0;
        while(i<str.size()){
            int j=i+1;
            while(j<str.size()&&str[j]==str[i]){
                j++;
            }
            if((j-i)%k!=0){
                chucked[str[i]]=0;
            }
            else if(chucked[str[i]]==-1){
                chucked[str[i]]=1;
            }
            i=j;
        }
        string r="";
        i=0;
        while(i<str.size()){
            r+=str[i];
            if(chucked[str[i]]){
                i+=k-1;
                if(!visited[str[i]]){
                    cout<<str[i];
                    visited[str[i]]=true;
                }
            }
            i++;
            
        }
        cout<<endl<<r;
        return 0;
    }
    
    
    


  • 相关阅读:
    3.学习SpringMVC注解深入
    1.Google Blockly概述以及入门
    4.Servlet的Response和Request
    3.Servlet的ServletContext对象
    提高网络点击率的八种方法
    JNDI知道这么多就够了!
    jetty源代码剖析
    cocos2d-x 源代码分析 : control 源代码分析 ( 控制类组件 controlButton)
    Codeforces Round #254 (Div. 2)B. DZY Loves Chemistry
    几款“理想”“习惯”应用体验报告
  • 原文地址:https://www.cnblogs.com/dreamzj/p/14466314.html
Copyright © 2011-2022 走看看