zoukankan      html  css  js  c++  java
  • 杭电1004 Let the Balloon Rise

    Let the Balloon Rise

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 79821    Accepted Submission(s): 30012


    Problem Description
    Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

    This year, they decide to leave this lovely job to you.
     

    Input
    Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

    A test case with N = 0 terminates the input and this test case is not to be processed.
     

    Output
    For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.
     

    Sample Input
    5 green red blue red red 3 pink orange pink 0
     

    Sample Output
    red pink
     

    Author
    WU, Jiazhi
     

    Source
    ZJCPC2004


    #include <string>
    #include <cstring>
    #include <iostream>
    using namespace std ;
    
    int main()
    {
        string s[1005] ;
        int n ,cnt[1005];
        while(cin>>n && n)
        {
            memset(cnt,0,sizeof(cnt)) ;
            for(int i = 0 ;i<n ;i++)
            {
                cin>>s[i] ;
                for(int j = 0 ; j<i; j++)
                {
                    if(s[i] == s[j])
                        cnt[i]++ ;
                }
            }
            int k = 0 ;
            int max = cnt[0] ;
            for(int i = 1 ;i<n ;i++)
            {
                if(cnt[i]>max)
                {
                    k = i ;
                    max = cnt[i] ;
                }
            }
            cout<<s[k]<<endl ;
        }
        return 0 ;
    }
    


  • 相关阅读:
    Nginx中工作进程(work-process)为多少合适?
    Ubuntu中安装启动Nginx
    怎么获得类加载器?
    XML解析方式有哪些?
    HashMap常见面试题
    IO流分类
    集合之间的区别
    css布局2
    css布局1
    css3 总结01
  • 原文地址:https://www.cnblogs.com/emoji/p/4436845.html
Copyright © 2011-2022 走看看