zoukankan      html  css  js  c++  java
  • A

    首先介绍一下next_permutation函数的用途!

    按照STL文档的描述,next_permutation函数将按字母表顺序生成给定序列的下一个较大的排列,直到整个序列为降序为止。

    prev_permutation函数与之相反,是生成给定序列的上一个较小的排列。

    代码如下

    #include<iostream>
    #include<algorithm>
    using namespace std;
    int main()
    {
        int a[] = {3,6,4,2};
    do{
         cout << a[0] << " " << a[1] << " " << a[2]<<" "<<a[3] << endl;
    }
    while (next_permutation(a,a+4));
    
        //system("pause");
        return 0;
    }

    3,6,4,2  下一个序列为 4 2 3 6

    观察第一个序列可以发现pn中的6 4 2已经为减序,在这个子集中再也无法排出更大的序列了,因此必须移动3的位置且要找一个数来取代3的位置。在6 4 2中6和4都比3大,但6比3大的太多了,只能选4。将4和3的位置对调后形成排列4 6 3 2。注意,由于4和3大小的相邻关系,对调后产生的子集6 3 2仍保持逆序,即该子集最大的一种排列。

    题目

    Description

    Now our hero finds the door to the BEelzebub feng5166. He opens the door and finds feng5166 is about to kill our pretty Princess. But now the BEelzebub has to beat our hero first. feng5166 says, "I have three question for you, if you can work them out, I will release the Princess, or you will be my dinner, too." Ignatius says confidently, "OK, at last, I will save the Princess."        
    "Now I will show you the first problem." feng5166 says, "Given a sequence of number 1 to N, we define that 1,2,3...N-1,N is the smallest sequence among all the sequence which can be composed with number 1 to N(each number can be and should be use only once in this problem). So it's easy to see the second smallest sequence is 1,2,3...N,N-1. Now I will give you two numbers, N and M. You should tell me the Mth smallest sequence which is composed with number 1 to N. It's easy, isn't is? Hahahahaha......"         Can you help Ignatius to solve this problem?        
                    

    Input

    The input contains several test cases. Each test case consists of two numbers, N and M(1<=N<=1000, 1<=M<=10000). You may assume that there is always a sequence satisfied the BEelzebub's demand. The input is terminated by the end of file.        
                    

    Output

    For each test case, you only have to output the sequence satisfied the BEelzebub's demand. When output a sequence, you should print a space between two numbers, but do not output any spaces after the last number.        
                    

    Sample Input

    6 4
    11 8
                    

    Sample Output

    1 2 3 5 6 4
    1 2 3 4 5 6 7 9 8 11 10
     
    就是利用这个神奇的函数即可完成
     
     
    #include<iostream>
    #include<algorithm>
    using namespace std;
    int main()
    {
        int n,m,a[1005];
        while(cin>>n>>m){
            for(int i=0;i<n;i++)a[i]=i+1;
            while(m-1){
                next_permutation(a,a+n);
                m--;
            }
            for(int i=0;i<n;i++){
                if(i!=n-1)cout<<a[i]<<" ";
                else cout<<a[i]<<endl;
            }
        }
        //system("pause");
        return 0;
    }
     
     
     
  • 相关阅读:
    macOS 修改键盘重复按键延迟
    stdout 与 stderr 区别
    E. 1-Trees and Queries
    Codeforces Round #615 (Div. 3)
    Codeforces Round 613(div 2)
    Codeforces Edu80
    SPOJ
    快读
    《货车运输》题解--最大生成树&倍增
    倍增思想求lca
  • 原文地址:https://www.cnblogs.com/farewell-farewell/p/5208217.html
Copyright © 2011-2022 走看看