zoukankan      html  css  js  c++  java
  • Section 1.1 Greedy Gift Givers

    Greedy Gift Givers

    A group of NP (2 ≤ NP ≤ 10) uniquely named friends hasdecided to exchange gifts of money. Each of these friends might ormight not give some money to any or all of the other friends.Likewise, each friend might or might not receive money from any orall of the other friends. Your goal in this problem is to deduce how much more money each person gives than they receive.

    The rules for gift-giving are potentially different than youmight expect. Each person sets aside a certain amount of money togive and divides this money evenly among all those to whom he orshe is giving a gift. No fractional money is available, so dividing3 among 2 friends would be 1 each for the friends with 1 left over-- that 1 left over stays in the giver's "account".

    In any group of friends, some people are more giving than others(or at least may have more acquaintances) and some people have moremoney than others.

    Given a group of friends, no one of whom has a name longer than14 characters, the money each person in the group spends on gifts,and a (sub)list of friends to whom each person gives gifts, determinehow much more (or less) each person in the group gives than theyreceive.

    IMPORTANT NOTE

    The grader machine is a Linux machine that uses standard Unixconventions: end of line is a single character often known as ' '.This differs from Windows, which ends lines with two charcters,' ' and ' '. Do not let your program get trapped by this!

    PROGRAM NAME: gift1

    INPUT FORMAT

    Line 1: The single integer, NP
    Lines 2..NP+1: Each line contains the name of a group member
    Lines NP+2..end: NP groups of lines organized like this:
    The first line in the group tells the person's name who will be giving gifts.
    The second line in the group contains two numbers: The initialamount of money (in the range 0..2000) to be divided up into gifts by the giverand then the number of people to whom the giver will give gifts,NGi (0 ≤ NGi ≤ NP-1).
    If NGi is nonzero, each of the next NGi lines lists the the name of a recipient of a gift.

    SAMPLE INPUT (file gift1.in)

    5
    dave
    laura
    owen
    vick
    amr
    dave
    200 3
    laura
    owen
    vick
    owen
    500 1
    dave
    amr
    150 2
    vick
    owen
    laura
    0 2
    amr
    vick
    vick
    0 0
    

    OUTPUT FORMAT

    The output is NP lines, each with the name of a person followed bya single blank followed by the net gain or loss (final_money_value - initial_money_value) for that person. The names should be printed inthe same order they appear on line 2 of the input.

    All gifts are integers. Each person gives the same integer amountof money to each friend to whom any money is given, and gives as muchas possible that meets this constraint. Any money not given is kept bythe giver.

    SAMPLE OUTPUT (file gift1.out)

    dave 302
    laura 66
    owen -359
    vick 141
    amr -150
    
    此题关键在于如何处理字符串所表示人的名字上,就是如何通过一个名字找到此人的位置,下面写了find()函数 用于返回名字所在的位置
    
    /*
    ID: ifayne1
    LANG: C++
    TASK: gift1
    */
    #include <iostream>
    #include <stdio.h>
    #include <string>
    
    #define NP 11
    
    using namespace std;
    
    struct _NP{
    	string name;
    	int have;
    }N[NP];
    
    int n;
    
    int find(string name)
    {
    	int i;
    	for ( i=0; i<n; i++ )
    	{
    		if ( name == N[i].name ) break;
    	}
    	return i;
    }
    
    void input()
    {
    	int amount, divide;
    	string temp;
    	cin >> temp;
    	cin >> amount >> divide;
    	if ( divide != 0 )
    	{
    		N[find(temp)].have = N[find(temp)].have - (amount - amount % divide);
    		for ( int i=0; i<divide; i++ )
    		{
    			cin >> temp;
    			N[find(temp)].have += (amount / divide);
    		}
        }
    }
    
    
    int main()
    {
    	freopen("gift1.in", "r", stdin);
    	freopen("gift1.out", "w", stdout);
    	int i;
    	cin >> n;
    	for ( i=0; i<n; i++ )
    	{
    			cin >> N[i].name;
    			N[i].have = 0;
    	}
    	for ( i=0; i<n; i++ )
    		input();
    	for ( i=0; i<n; i++ )
    		cout << N[i].name << " " << N[i].have << endl;
    	return 0;
    }



  • 相关阅读:
    solr 使用
    深入理解java虚拟机(二)HotSpot Java对象创建,内存布局以及访问方式
    深入理解java虚拟机(一)
    获取请求体数据 POST
    获取请求头数据
    Servlet之Request和Response 解析
    Servlet 之 Http协议
    Servlet 体系结构
    如何修改servlet的创建时机?
    Java Web servlet 详解
  • 原文地址:https://www.cnblogs.com/fayne/p/7224809.html
Copyright © 2011-2022 走看看