zoukankan      html  css  js  c++  java
  • POJ 1080 Human Gene Functions

    Time Limit: 1000MS

     

    Memory Limit: 10000K

    Total Submissions: 20750

     

    Accepted: 11563

    Description

    It is well known that a human gene can be considered as a sequence, consisting of four nucleotides, which are simply denoted by four letters, A, C, G, and T. Biologists have been interested in identifying human genes and determining their functions, because these can be used to diagnose human diseases and to design new drugs for them.

    A human gene can be identified through a series of time-consuming biological experiments, often with the help of computer programs. Once a sequence of a gene is obtained, the next job is to determine its function.
    One of the methods for biologists to use in determining the function of a new gene sequence that they have just identified is to search a database with the new gene as a query. The database to be searched stores many gene sequences and their functions – many researchers have been submitting their genes and functions to the database and the database is freely accessible through the Internet.

    A database search will return a list of gene sequences from the database that are similar to the query gene.
    Biologists assume that sequence similarity often implies functional similarity. So, the function of the new gene might be one of the functions that the genes from the list have. To exactly determine which one is the right one another series of biological experiments will be needed.

    Your job is to make a program that compares two genes and determines their similarity as explained below. Your program may be used as a part of the database search if you can provide an efficient one.
    Given two genes AGTGATG and GTTAG, how similar are they? One of the methods to measure the similarity
    of two genes is called alignment. In an alignment, spaces are inserted, if necessary, in appropriate positions of
    the genes to make them equally long and score the resulting genes according to a scoring matrix.

    For example, one space is inserted into AGTGATG to result in AGTGAT-G, and three spaces are inserted into GTTAG to result in –GT--TAG. A space is denoted by a minus sign (-). The two genes are now of equal
    length. These two strings are aligned:

    AGTGAT-G
    -GT--TAG

    In this alignment, there are four matches, namely, G in the second position, T in the third, T in the sixth, and G in the eighth. Each pair of aligned characters is assigned a score according to the following scoring matrix.

     


    denotes that a space-space match is not allowed. The score of the alignment above is (-3)+5+5+(-2)+(-3)+5+(-3)+5=9.

    Of course, many other alignments are possible. One is shown below (a different number of spaces are inserted into different positions):

    AGTGATG
    -GTTA-G

    This alignment gives a score of (-3)+5+5+(-2)+5+(-1) +5=14. So, this one is better than the previous one. As a matter of fact, this one is optimal since no other alignment can have a higher score. So, it is said that the
    similarity of the two genes is 14.

    Input

    The input consists of T test cases. The number of test cases ) (T is given in the first line of the input file. Each test case consists of two lines: each line contains an integer, the length of a gene, followed by a gene sequence. The length of each gene sequence is at least one and does not exceed 100.

    Output

    The output should print the similarity of each test case, one per line.

    Sample Input

    2

    7 AGTGATG

    5 GTTAG

    7 AGCTATT

    9 AGCTTTAAA

    Sample Output

    14

    21

     

    package POJ;
    
    import java.util.HashMap;
    import java.util.Map;
    import java.util.Scanner;
    
    public class P1080 {
        /*
        A   C   G   T   -
        0   1   2   3   4
    
           A  C  G  T  -
        A  5  -1 -2 -1 -3
        C  -1 5  -3 -2 -4
        G  -2 -3 5  -2 -2
        T  -1 -2 -2 5  -1
        -  -3 -4 -2 -1 *
         */
        public static int getMax(int a,int b,int c){
            return Math.max(Math.max(a,b),Math.max(a,c));
        }
        public static void main(String args[]) {
            int[][] score={ {5, -1, -2,    -1,    -3},
                            {-1, 5,    -3,    -2,    -4},
                            {-2,-3, 5, -2,    -2},
                            {-1,-2,    -2,     5,    -1},
                            {-3,-4,    -2,    -1,     0} };
            Map<Character,Integer> map=new HashMap<Character, Integer>();
            map.put('A',0);
            map.put('C',1);
            map.put('G',2);
            map.put('T',3);
            map.put('-',4);
            Scanner cin=new Scanner(System.in);
            int pairs=Integer.valueOf(cin.nextLine().substring(0,1));//基因对数。主要是对数后面跟了个空格,不能直接转为数字
            for(int k=0;k<pairs;k++)
            {
                //int similarity=0;
                String str1=cin.nextLine();
                int spaceIndex1=str1.indexOf(" ");//index是第一个空格的index
                int len1=Integer.valueOf(str1.substring(0,spaceIndex1));
                String seq1=str1.substring(spaceIndex1+1,spaceIndex1+len1+1);
                String str2=cin.nextLine();
                int spaceIndex2=str1.indexOf(" ");
                int len2=Integer.valueOf(str2.substring(0,spaceIndex2));
                String seq2=str2.substring(spaceIndex2+1,spaceIndex2+len2+1);
                int[][] dp=new int[len1+1][len2+1];//dp[i][j]用来表示字符串s1  1~i的和字符串序列s2 1~j的最大相似度
                /*
                三种情况:
                Ai和Bj匹配
                Ai和空格匹配,A_(i-1)再和B_j匹配
                Bj和空格匹配,A_i再和B_(j-1)匹配
                 */
                /*
                dp数组边缘初始化
                dp[i][j] = max{dp[i-1][j-1]+value(a[i],b]j],dp[i][j-1]+value(-,b[j]), dp[i-1][j]+value(a[i],-)}
                 */
                dp[0][0] = 0;
                for(int i=0;i<len1;i++)//字符串下标0~len1-1。dp下标0~len1
                {
                    dp[i+1][0] = dp[i][0] + score[map.get(seq1.charAt(i))][map.get('-')];
                }
                for(int j=0;j<len2;j++)
                {
                    /*System.out.println(dp[0][j]);
                    System.out.println(seq2.charAt(j));
                    System.out.println(map.get(seq2.charAt(j)));
                    System.out.println(score[map.get('-')][map.get(seq2.charAt(j))]);
                    System.out.println(dp[0][j+1]);*/
                    dp[0][j+1] = dp[0][j] + score[map.get('-')][map.get(seq2.charAt(j))];
                }
    
                for(int i=1;i<=len1;i++){
                    for(int j=1;j<=len2;j++){
                        /*
                        dp下标与seq下标不同
                        大1
                         */
                        dp[i][j]=getMax(dp[i-1][j-1] + score[map.get(seq1.charAt(i-1))][map.get(seq2.charAt(j-1))],
                                dp[i-1][j] +score[map.get(seq1.charAt(i-1))][map.get('-')] ,
                                dp[i][j-1] + score[map.get('-')][map.get(seq2.charAt(j-1))]);
                    }
                }
    /*            for(int i=0;i<=len1;i++){
                    for(int j=0;j<=len2;j++){
                        *//*
                        dp下标与seq下标不同
                        大1
                         *//*
                        System.out.print(dp[i][j]+"	");
                    }
                    System.out.println();
                }*/
                System.out.println(dp[len1][len2]);
            }
        }
    }
    

     

    博客园的编辑器没有CSDN的编辑器高大上啊
  • 相关阅读:
    [原]C++ double 小数精度控制
    C++ double 小数精度控制
    从微软小冰看微软运营手段的转型
    Windows下搭建FTP服务器
    C++ 下使用curl 获取ftp文件
    解决MSF更新证书错误
    mimikaz获取明文密码
    metasploit5配置数据库
    Cobalt Strike几种不常见的上线方式
    Powershell
  • 原文地址:https://www.cnblogs.com/flowingfog/p/9765927.html
Copyright © 2011-2022 走看看