zoukankan      html  css  js  c++  java
  • hdu 1690 bus system

    Bus System

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 2894    Accepted Submission(s): 723


    Problem Description
    Because of the huge population of China, public transportation is very important. Bus is an important transportation method in traditional public transportation system. And it’s still playing an important role even now.
    The bus system of City X is quite strange. Unlike other city’s system, the cost of ticket is calculated based on the distance between the two stations. Here is a list which describes the relationship between the distance and the cost.



    Your neighbor is a person who is a really miser. He asked you to help him to calculate the minimum cost between the two stations he listed. Can you solve this problem for him?
    To simplify this problem, you can assume that all the stations are located on a straight line. We use x-coordinates to describe the stations’ positions.
     
    Input
    The input consists of several test cases. There is a single number above all, the number of cases. There are no more than 20 cases.
    Each case contains eight integers on the first line, which are L1, L2, L3, L4, C1, C2, C3, C4, each number is non-negative and not larger than 1,000,000,000. You can also assume that L1<=L2<=L3<=L4.
    Two integers, n and m, are given next, representing the number of the stations and questions. Each of the next n lines contains one integer, representing the x-coordinate of the ith station. Each of the next m lines contains two integers, representing the start point and the destination.
    In all of the questions, the start point will be different from the destination.
    For each case,2<=N<=100,0<=M<=500, each x-coordinate is between -1,000,000,000 and 1,000,000,000, and no two x-coordinates will have the same value.
     
    Output
    For each question, if the two stations are attainable, print the minimum cost between them. Otherwise, print “Station X and station Y are not attainable.” Use the format in the sample.
     
    Sample Input
    2 1 2 3 4 1 3 5 7 4 2 1 2 3 4 1 4 4 1 1 2 3 4 1 3 5 7 4 1 1 2 3 10 1 4
     
    Sample Output
    Case 1: The minimum cost between station 1 and station 4 is 3. The minimum cost between station 4 and station 1 is 3. Case 2: Station 1 and station 4 are not attainable.
     
    Source
     
    Recommend
    wangye
     
     
    错了n次 就是因为坐标位置
    代码

    #include<iostream>
    using namespace std;
     const __int64  maxint=999999999999;
    __int64 w[105][105],lowcost[105],C[5];
    int L[5],p[105],bin[105],vis[105];
    int n;

    int findx(int x)
    {
     if(bin[x]==-1) { bin[x]=x; return x;}
     while(x!=bin[x]) x=bin[x];
     return x;
    }

    void Dijkstra(int s,int t)
    {
     int i,j,k;
     for(i=1;i<=n;i++) lowcost[i]=w[s][i],vis[i]=0;
     lowcost[s]=0,vis[s]=1;
     for(i=1;i<n;i++)
     {
      __int64 minx=maxint;
      for(j=1;j<=n;j++)
       if(!vis[j]&&lowcost[j]<minx)
        minx=lowcost[j],k=j;
      vis[k]=1;
      for(j=1;j<=n;j++)
       if(!vis[j]&&lowcost[j]-lowcost[k]>w[k][j])
        lowcost[j]=lowcost[k]+w[k][j];
     }
     if(lowcost[t]<maxint)
      printf("The minimum cost between station %d and station %d is %I64d.\n",s,t,lowcost[t]);
     else
      printf("Station %d and station %d are not attainable.\n",s,t);

    }

    int main()
    {
     int i,j,m,t,cnt,x,y;
     while(scanf("%d",&t)==1&&t)
     {
      cnt=1;
      while(t--)
      {
       printf("Case %d:\n",cnt++);
       for(i=1;i<=4;i++)
        scanf("%d",&L[i]);
       for(i=1;i<=4;i++)
        scanf("%I64d",&C[i]);
       scanf("%d%d",&n,&m);
       for(i=1;i<=n;i++)
        for(j=1;j<=n;j++) w[i][j]=maxint;
       memset(bin,-1,sizeof(bin));
       for(i=1;i<=n;i++)
       {
        scanf("%d",&p[i]);
        for(j=1;j<=i;j++)
        {
         int t=p[i]-p[j];
         if(t<=0) t=-t;/////////尼玛 bt 此时数据的坐标位置不是从小到大的,因为这一句wrong了9次
         if(t<=L[1])     w[i][j]=w[j][i]=C[1];
         else if(t<=L[2])w[i][j]=w[j][i]=C[2];
         else if(t<=L[3])w[i][j]=w[j][i]=C[3];
         else if(t<=L[4])w[i][j]=w[j][i]=C[4];
         else continue;
         x=i,y=j;
         x=findx(x),y=findx(y);
         if(x!=y)
          bin[x]=y;
        }
       }
       while(m--)
       {
        scanf("%d%d",&x,&y);
        if(x==y)
        {
         printf("The minimum cost between station %d and station %d is 0.\n",x,x);
                        continue;
        }
        if(x>n||y>n||findx(x)!=findx(y))
        {
         printf("Station %d and station %d are not attainable.\n",x,y);
         continue;
        }
        Dijkstra(x,y);
       }
      }
     }
     return 0;
    }

    floyd:

    #include<iostream>
    using namespace std;
    #define maxint 1000000000000
    __int64 w[105][105],lowcost[105][105],C[5];
    int L[5],p[105],bin[105],vis[105];
    int n;

    int main()
    {
     int i,j,m,t,cnt,x,y,k;
     while(scanf("%d",&t)==1&&t)
     {
      cnt=1;
      while(t--)
      {
       printf("Case %d:\n",cnt++);
       for(i=1;i<=4;i++)
        scanf("%d",&L[i]);
       for(i=1;i<=4;i++)
        scanf("%I64d",&C[i]);
       scanf("%d%d",&n,&m);
       for(i=1;i<=n;i++)
        for(j=1;j<=n;j++) w[i][j]=maxint;
       for(i=1;i<=n;i++)
       {
        scanf("%d",&p[i]);
        for(j=1;j<=i;j++)
        {
         int t=p[i]-p[j];
         if(t<0) t=-t;
         if(t<=L[1])     w[i][j]=w[j][i]=C[1];
         else if(t<=L[2])w[i][j]=w[j][i]=C[2];
         else if(t<=L[3])w[i][j]=w[j][i]=C[3];
         else if(t<=L[4])w[i][j]=w[j][i]=C[4];
         else continue;
        }
       }
       for(k=1;k<=n;k++)
        for(i=1;i<=n;i++)
         for(j=1;j<=n;j++)
          if(w[i][j]-w[i][k]>w[k][j])
           w[i][j]=w[i][k]+w[k][j];
       while(m--)
       {
        scanf("%d%d",&x,&y);
        if(x==y)
        {
         printf("The minimum cost between station %d and station %d is 0.\n",x,x);
                        continue;
        }
        if(x>n||y>n||x<=0||y<=0)
        {
         printf("Station %d and station %d are not attainable.\n",x,y);
         continue;
        }
        if(w[x][y]<maxint)
         printf("The minimum cost between station %d and station %d is %I64d.\n",x,y,w[x][y]);
        else
         printf("Station %d and station %d are not attainable.\n",x,y);
       }
      }
     }
     return 0;
    }

  • 相关阅读:
    Servlet的生命周期?
    C++图结构的图结构操作示例
    如何从google play下载app应用,直接下载apk
    C# Socket异步聊天例子
    三极管饱和,放大,截止电压判断
    java中的浮点(float)运算
    微软2014校园招聘笔试试题
    软件开发中的资源控制问题学习
    linux mount命令学习
    17、Spring Boot普通类调用bean【从零开始学Spring Boot】
  • 原文地址:https://www.cnblogs.com/forgood/p/2229212.html
Copyright © 2011-2022 走看看