zoukankan      html  css  js  c++  java
  • hdu 1506 Largest Rectangle in a Histogram

    题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1506

    Largest Rectangle in a Histogram

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 5475    Accepted Submission(s): 1570

    Problem Description
    A histogram is a polygon composed of a sequence of rectangles aligned at a common base line. The rectangles have equal widths but may have different heights. For example, the figure on the left shows the histogram that consists of rectangles with the heights 2, 1, 4, 5, 1, 3, 3, measured in units where 1 is the width of the rectangles:

    Usually, histograms are used to represent discrete distributions, e.g., the frequencies of characters in texts. Note that the order of the rectangles, i.e., their heights, is important. Calculate the area of the largest rectangle in a histogram that is aligned at the common base line, too. The figure on the right shows the largest aligned rectangle for the depicted histogram.
     
    Input
    The input contains several test cases. Each test case describes a histogram and starts with an integer n, denoting the number of rectangles it is composed of. You may assume that 1 <= n <= 100000. Then follow n integers h1, ..., hn, where 0 <= hi <= 1000000000. These numbers denote the heights of the rectangles of the histogram in left-to-right order. The width of each rectangle is 1. A zero follows the input for the last test case.
     
    Output
    For each test case output on a single line the area of the largest rectangle in the specified histogram. Remember that this rectangle must be aligned at the common base line.
     
    Sample Input
    7 2 1 4 5 1 3 3 4 1000 1000 1000 1000 0
     
    Sample Output
    8 4000
     
    Source
     
    Recommend
    LL
     

    题意:即求最大的矩形面积。

    状态转移方程:

    for(i=1;i<=n;i++)
            {
            	area=hi[i]*(right[i]-left[i]+1);
            	ans = ans > area ? ans : area;
            }

    主要是确定满足条件的矩形的位置。

    对于对应的矩形,如果其高于自己左边的矩形,那么满足左边的矩形必定满足其本身,右边也如此:

    for(i=1;i<=n;i++)
    		   while(hi[left[i]-1]>=hi[i])
    		        left[i]=left[left[i]-1];
            for(i=n;i>=1;i--)
                while(hi[right[i]+1]>=hi[i])
                    right[i]=right[right[i]+1];

    看了N多博客后纠结出的代码,有待学习的地方还有很多啊~~~~~~

    //AC 62ms 1820k
    #include<stdio.h>
    const int maxn=100010;
    int left[maxn],right[maxn];
    __int64 hi[maxn],ans,area;
    int main()
    {
        int i,n;
        while(scanf("%d",&n)!=EOF && n)
        {
            area=ans=0;
            for(i=1;i<=n;i++)
            {
                scanf("%I64d",&hi[i]);
                right[i]=left[i]=i;
            }
            hi[0]=hi[n+1]=-1;
            for(i=1;i<=n;i++)
               while(hi[left[i]-1]>=hi[i])
                    left[i]=left[left[i]-1];
            for(i=n;i>=1;i--)
                while(hi[right[i]+1]>=hi[i])
                    right[i]=right[right[i]+1];
            for(i=1;i<=n;i++)
            {
                area=hi[i]*(right[i]-left[i]+1);
                ans = ans > area ? ans : area;
            }
            printf("%I64d\n",ans);
        }
        return 0;
    }



  • 相关阅读:
    Gym 101606 F-Flipping Coins(概率dp)
    Gym101350 J Lazy Physics Cat
    Gym 101350G
    hdu6188 Duizi and Shunzi (贪心或者dp)
    Gym101350 FMonkeying Around
    codeforce 457DIV2 C题
    codeforce 457DIV2 B题
    codeforce 461DIV2 F题
    codeforce 461DIV2 E题
    PE文件RV转FOA及FOA转RVA
  • 原文地址:https://www.cnblogs.com/freezhan/p/2638877.html
Copyright © 2011-2022 走看看