zoukankan      html  css  js  c++  java
  • POJ 3041 Asteroids 【匈牙利算法最小点覆盖】

    原题链接http://poj.org/problem?id=3041

    题目来源http://acm.hust.edu.cn:8080/judge/contest/view.action?cid=16967#problem/E

    算法:匈牙利算法(二分匹配,求最小点覆盖数)

    Asteroids
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 10768   Accepted: 5823

    Description

    Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at the lattice points of the grid. 

    Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.

    Input

    * Line 1: Two integers N and K, separated by a single space. 
    * Lines 2..K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.

    Output

    * Line 1: The integer representing the minimum number of times Bessie must shoot.

    Sample Input

    3 4
    1 1
    1 3
    2 2
    3 2
    

    Sample Output

    2
    

    Hint

    INPUT DETAILS: 
    The following diagram represents the data, where "X" is an asteroid and "." is empty space: 
    X.X 
    .X. 
    .X.
     

    OUTPUT DETAILS: 
    Bessie may fire across row 1 to destroy the asteroids at (1,1) and (1,3), and then she may fire down column 2 to destroy the asteroids at (2,2) and (3,2).

    Source


    题意给出一个N*N的矩阵,有的位置有行星。已知一枪可以击溃一行或一列上的所有行星。问最少多少枪可以击溃       所有的行星。

    思路:以行作为X集合,以列作为Y集合,一个行星在(x,y),则x对应X中的点向y对应Y中的点连一条边,则某个顶点一       旦被选,则与之相连的边(也就是行星)都会被选,也就是选出最少的顶点覆盖所有的边,即最小顶点覆盖。

    算法:

          Konig定理:一个二分图中的最大匹配数等于这个图中的最小点覆盖数。

          最小点覆盖数:假如选中了一个点就相当于覆盖了以它为端点的所有边,你需要选择最少的点覆盖所有的边。

    PS:模板题目,直接套用匈牙利算法求最大的匹配数的模板即可。关键是理解如何建图。

    #include<stdio.h>
    #include<string.h>
    const int maxn=510;
    int g[maxn][maxn];
    int linker[maxn];
    bool used[maxn];
    int n,m;
    int uN,vN;
    int find(int u)
    {
        int v;
        for(v=1;v<=vN;v++)
        {
            if(!used[v] && g[u][v])
            {
                used[v]=true;
                if(linker[v]==-1 || find(linker[v]))
                {
                    linker[v]=u;
                    return true;
                }
            }
        }
        return false;
    }
    int hugary()
    {
        int u;
        int sum=0;
        memset(linker,-1,sizeof(linker));
        for(u=1;u<=uN;u++)
        {
            memset(used,false,sizeof(used));
            if(find(u))   sum++;
        }
        return sum;
    }
    int main()
    {
        int u,v;
        while(scanf("%d%d",&n,&m)!=EOF)
        {
            uN=vN=n;
            memset(g,0,sizeof(g));
            while(m--)
            {
                scanf("%d%d",&u,&v);
                g[u][v]=1;
            }
            printf("%d\n",hugary());
        }
    }
    


          

       

  • 相关阅读:
    ubuntu 安装PHP
    修改rm 防止误删除
    游标输出
    微软已经提供了好几个开源的小项目供学习参考
    数据库存取时间比较
    UML建模工具比较
    16进制与BYTE类型转换
    显示有换行字符的提示框
    ORACLE数据库中主要字段类型的读写例子(包括:Long、Raw、Blob)
    .net 动态sql 参数应用 oracle和sql server的比较
  • 原文地址:https://www.cnblogs.com/freezhan/p/2974240.html
Copyright © 2011-2022 走看看