zoukankan      html  css  js  c++  java
  • 杭电 1016 Prime Ring Problem

    Prime Ring Problem

    Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 25187    Accepted Submission(s): 11246


    Problem Description
    A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

    Note: the number of first circle should always be 1.


     

    Input
    n (0 < n < 20).
     

    Output
    The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

    You are to write a program that completes above process.

    Print a blank line after each case.
     

    Sample Input
    6 8
     

    Sample Output
    Case 1: 1 4 3 2 5 6 1 6 5 2 3 4 Case 2: 1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2 1 6 7 4 3 8 5 2
     

    Source
     
    注意边界  还有首尾推断是否符合条件   
    #include<iostream>
    #include<cmath>
    #include<cstring>
    #include<algorithm>
    #define M 25
    using namespace std;
    int vis[M],n,ans[M],t=0;
    int sum(int a,int b)//判定素数的函数
    {
         int k=0,sum,i;
        sum=a+b;
            for(i=2;i<sum;i++)
                {
                    if(sum%i==0)
                        {
                            k=1;
                         return 0;
                        }
                }
                if(!k)
                     return 1;
    }
    
    void dfs(int x)
    {
        int i;
    
        if(x==n&&sum(ans[0],ans[n-1]))//递归边界   判定首尾是否符合条件
             {
    
                 for(i=0;i<n;i++)
                   {
    
                    if(i==0)
                        cout<<ans[0];
                    else
                       cout<<" "<<ans[i];
    
                   }
                   cout<<endl;
             }
        else
          {
            for(i=2;i<=n;i++)
               {
                    if(!vis[i]&&sum(i,ans[x-1]))
                      {
                           {
                               ans[x]=i;
                               vis[i]=1;//标记用过的数
                               dfs(x+1);
                               vis[i]=0;//还原用过的数
                           }
                     }
    
               }
          }
    }
    int main()
    {
        int i,j;
        while(cin>>n)
        {
    
            t++;
            memset(vis,0,sizeof(vis));
            cout<<"Case "<<t<<":"<<endl;
                vis[1]=1;ans[0]=1;
                dfs(1);
                cout<<endl;//每一个例子之间有一个空行
        }
    
        return 0;
    }
    

  • 相关阅读:
    BZOJ 5358 口算训练/HDU 6287(可持久化线段树)
    HDU 4288 Coder
    FZU 2289 项链
    jQuery
    HTML5存储技术Storage
    JS第三部分--BOM浏览器对象模型
    JS第二部分--DOM文档对象模型
    JS第一部分--ECMAScript5.0标准语法 (JS基础语法)
    python离线安装包
    DB2不记日志插入,python迭代器操作xlrd,python操作xlwt
  • 原文地址:https://www.cnblogs.com/gcczhongduan/p/4071857.html
Copyright © 2011-2022 走看看