zoukankan      html  css  js  c++  java
  • 1064. Complete Binary Search Tree (30)

    A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

    • The left subtree of a node contains only nodes with keys less than the node's key.
    • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
    • Both the left and right subtrees must also be binary search trees.

    A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.

    Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains a positive integer N (<=1000). Then N distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.

    Output Specification:

    For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

    Sample Input:

    10
    1 2 3 4 5 6 7 8 9 0
    

    Sample Output:

    6 3 8 1 5 7 9 0 2 4


    解题思路:搜索二叉树的中序遍历是一个递增的序列。所以需要把输入的序列sort一下。还有一个完全二叉树的性质是:下标为i的节点,它的左儿子下标2*i,右儿子2*i+1。

    #include<iostream>
    #include<cstdio>
    #include<vector>
    #include<algorithm>
    using namespace std;
    #define max 1005
    int root[max];
    int val[max];
    int n,m;
    bool cmp(int a, int b){
    	return a<b;
    }
    void build(int index){
    	if(index>n)return;
    	int left=index*2;
    	int right=index*2+1;
    	build(left);
    	root[index]=val[m++];
    	build(right);
    }
    int main(){
    	scanf("%d",&n);
    	int i,j;
    	for(i=0;i<n;i++){
    		scanf("%d",&val[i]);
    	}
    	sort(val,val+n,cmp);
    	m=0;
    	build(1);
    	printf("%d",root[1]);
    	for(i=2;i<n+1;i++){
    		printf(" %d",root[i]);
    	}
    	return 0;
    } 
    

      

  • 相关阅读:
    剑指offer——最小的K个数和数组中第K大的元素
    Leetcode刷题指南链接整理
    160. Intersection of Two Linked Lists
    100. Same Tree
    92. Reverse Linked List II
    94. Binary Tree Inorder Traversal
    79. Word Search
    78,90,Subsets,46,47,Permutations,39,40 DFS 大合集
    0x16 Tire之最大的异或对
    0x16 Tire
  • 原文地址:https://www.cnblogs.com/grglym/p/7840236.html
Copyright © 2011-2022 走看看