zoukankan      html  css  js  c++  java
  • 1006 Sign In and Sign Out

    At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in's and out's, you are supposed to find the ones who have unlocked and locked the door on that day.

    Input Specification:

    Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:

    ID_number Sign_in_time Sign_out_time
    
     

    where times are given in the format HH:MM:SS, and ID_number is a string with no more than 15 characters.

    Output Specification:

    For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.

    Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.

    Sample Input:

    3
    CS301111 15:30:28 17:00:10
    SC3021234 08:00:00 11:25:25
    CS301133 21:45:00 21:58:40
    
     

    Sample Output:

    SC3021234 CS301133

    题意:

    给出n个员工的编号,上班时间和下班时间,找出最早到公司和最晚离开公司的那个人的编号。

    Code:

    #include<iostream>
    #include<algorithm>
    
    using namespace std;
    
    typedef struct Person
    {
        string num;
        string signIn;
        string signOut;
    } person;
    
    person p[1000];
    
    bool Cmpare_in(person a, person b) {
        return a.signIn < b.signIn;
    }
    
    bool Cmpare_out(person a, person b) {
        return a.signOut > b.signOut;
    }
    
    int main() {
        int n;
        cin >> n;
    
        for (int i = 0; i < n; ++i) {
            string n, si, so;
            cin >> n >> si >> so;
            p[i].num = n, p[i].signIn = si, p[i].signOut = so;
        }
    
        sort(p, p+n, Cmpare_in);
        cout << p[0].num;
        sort(p, p+n, Cmpare_out);
        cout << " " << p[0].num;
    
        return 0;
    }
    

      

    永远渴望,大智若愚(stay hungry, stay foolish)
  • 相关阅读:
    ubuntu 开启ssh
    ubuntu 电源管理
    吸血鬼数
    java泛型
    分布式数据库主键id生成策略
    使用SSH工具连接到MySQL
    MySQL命令行基本命令操作
    bootstrap图片轮播
    java设计模式----工厂模式
    java设计模式----享元模式
  • 原文地址:https://www.cnblogs.com/h-hkai/p/12573530.html
Copyright © 2011-2022 走看看