zoukankan      html  css  js  c++  java
  • POJ 2253 Frogger(dijkstra 最短路

    POJ 2253 Frogger

    Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists' sunscreen, he wants to avoid swimming and instead reach her by jumping.
    Unfortunately Fiona's stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps.
    To execute a given sequence of jumps, a frog's jump range obviously must be at least as long as the longest jump occuring in the sequence.
    The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones.

    You are given the coordinates of Freddy's stone, Fiona's stone and all other stones in the lake. Your job is to compute the frog distance between Freddy's and Fiona's stone.

    Input

    The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy's stone, stone #2 is Fiona's stone, the other n-2 stones are unoccupied. There's a blank line following each test case. Input is terminated by a value of zero (0) for n.

    Output

    For each test case, print a line saying "Scenario #x" and a line saying "Frog Distance = y" where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.

    Sample Input

    2
    0 0
    3 4
    
    3
    17 4
    19 4
    18 5
    
    0
    

    Sample Output

    Scenario #1
    Frog Distance = 5.000
    
    Scenario #2
    Frog Distance = 1.414

    #include<iostream>
    #include<cmath>
    #include<cstdio>
    #define inf 10000000
    using namespace std;
    struct ac{
        int x,y;
    }a[1000];
    double temp[2005][2005],dis[1005];
    void dijkstra(int n){
        double minn;
        int flag,vis[2005]={0};
        for(int i = 0;i < n;++i)dis[i]=temp[0][i];
        for(int i = 0;i < n-1;++i){
            minn=inf;flag=0;
            for(int j = 1;j < n;++j){
                if(minn>dis[j]&&!vis[j])minn=dis[j],flag=j;
            }
            vis[flag]=1;
            for(int j = 1;j < n;++j){
            dis[j]=min(dis[j],max(dis[flag],temp[flag][j]));
            }
        }
    }
    int main()
    {
        int m,ans=1;
        while(cin>>m&&m){
            for(int i = 0;i < m;++i)cin>>a[i].x>>a[i].y;
        //    ac tempp=a[m-1];a[m-1]=a[1],a[1]=tempp;
            for(int i = 0;i < m;++i){
                for(int j = 0;j < m;++j){
                    temp[i][j]=temp[j][i]=sqrt((a[i].x-a[j].x)*(a[i].x-a[j].x)+(a[i].y-a[j].y)*(a[i].y-a[j].y));
                }
            }
            dijkstra(m);
            if(ans!=1)cout<<endl;
            printf("Scenario #%d
    Frog Distance = %.3f
    ",ans++,dis[1]);
        }
    }
    AC代码

    没想到最后是被输出格式卡了。。晕。。

  • 相关阅读:
    js下拉框二级关联菜单效果代码具体实现
    js实现拉伸拖动iframe的具体代码
    mysql--Ubuntu下设置MySQL字符集为utf8
    python--使用MySQL数据库
    python--笨方法学python 习题52
    python--web.py使用
    python--flask使用
    python--类方法、对象方法、静态方法
    Python--类定义
    堆 在游戏中的运用
  • 原文地址:https://www.cnblogs.com/h404nofound/p/11608221.html
Copyright © 2011-2022 走看看