zoukankan      html  css  js  c++  java
  • LA-3135

      

    3135 - Argus

      A data stream is a real-time, continuous, ordered sequence of items. Some examples include sensor
    data, Internet traffic, financial tickers, on-line auctions, and transaction logs such as Web usage logs
    and telephone call records. Likewise, queries over streams run continuously over a period of time and
    incrementally return new results as new data arrives. For example, a temperature detection system of
    a factory warehouse may run queries like the following.
    Query-1: “Every five minutes, retrieve the maximum temperature over the past five minutes.”
    Query-2: “Return the average temperature measured on each floor over the past 10 minutes.”
    We have developed a Data Stream Management System called Argus, which processes the queries
    over the data streams. Users can register queries to the Argus. Argus will keep the queries running
    over the changing data and return the results to the corresponding user with the desired frequency.
    For the Argus, we use the following instruction to register a query:
    Register Q num P eriod
    Q num (0 < Qnum ≤ 3000) is query ID-number, and P eriod (0 < P eriod ≤ 3000) is the interval
    between two consecutive returns of the result. After P eriod seconds of register, the result will be
    returned for the first time, and after that, the result will be returned every P eriod seconds.
    Here we have several different queries registered in Argus at once. It is confirmed that all the
    queries have different Q num. Your task is to tell the first K queries to return the results. If two or
    more queries are to return the results at the same time, they will return the results one by one in the
    ascending order of Q num.
    Input
    The first part of the input are the register instructions to Argus, one instruction per line. You can
    assume the number of the instructions will not exceed 1000, and all these instructions are executed at
    the same time. This part is ended with a line of ‘#’.
    The second part is your task. This part contains only one line, which is one positive integer K
    (≤ 10000).
    Output
    You should output the Q num of the first K queries to return the results, one number per line.
    Sample Input
    Register 2004 200
    Register 2005 300
    #
    5
    Sample Output

    2004
    2005
    2004
    2004
    2005

    题解:就是给你一系列事件,每隔一定时间会发生一次,然后让输出事件的发生,注意队列要想从小到大,应该是》。。。我咋说一直答案不对的;优先队列搞了下,ac了

    代码:

    #include<iostream>
    #include<cstdio>
    #include<cstring>
    #include<cmath>
    #include<algorithm>
    #include<queue>
    #include<vector>
    #include<stack>
    using namespace std;
    const int INF=0x3f3f3f3f;
    #define mem(x,y) memset(x,y,sizeof(x))
    #define SI(x) scanf("%d",&x)
    #define SL(x) scanf("%lld",&x)
    #define PI(x) printf("%d",x)
    #define PL(x) printf("%lld",x)
    #define P_ printf(" ")
    #define T_T while(T--)
    #define F(i,s,x) for(i=s;i<x;i++)
    const double PI=acos(-1.0);
    typedef long long LL;
    struct Node{
    	int v,t,num;
    	Node(int v=0,int t=0,int num=1):v(v),t(t),num(num){}
    	friend bool operator < (Node a,Node b){
    		if(a.t*a.num!=b.t*b.num)return a.t*a.num>b.t*b.num;
    		else return a.v>b.v;
    	}
    };
    int main(){
    	char s[10];
    	Node a;
    	priority_queue<Node>dl;
    	while(scanf("%s",s),strcmp(s,"#")){
    		scanf("%d%d",&a.v,&a.t);
    		dl.push(a);
    	}
    	int x;
    	SI(x);
    	//while(!dl.empty())PI(dl.top().t*dl.top().num),P_,dl.pop();
    	while(x--){
    		a=dl.top();	
    		dl.pop();
    		PI(a.v);puts("");
    		a.num++;
    		dl.push(a);
    	}
    	return 0;
    }
    

      

  • 相关阅读:
    数据访问技术系列课程 笔记(2) ADO.NET 连接方式进行数据访问
    Modern C# 系列课程笔记 第11节 深入委托和事件
    idea 将项目托管到 Git 报错:Can't finish Gitee sharing process
    ADO.Net
    WebService
    2013年了
    201301杂谈
    流程图
    出错列表
    杂谈4 2012年8月15日开
  • 原文地址:https://www.cnblogs.com/handsomecui/p/5011315.html
Copyright © 2011-2022 走看看