zoukankan      html  css  js  c++  java
  • [HDU 1160] FatMouse's Speed

    FatMouse's Speed

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 10872    Accepted Submission(s): 4774
    Special Judge


    Problem Description
    FatMouse believes that the fatter a mouse is, the faster it runs. To disprove this, you want to take the data on a collection of mice and put as large a subset of this data as possible into a sequence so that the weights are increasing, but the speeds are decreasing.
     
    Input
    Input contains data for a bunch of mice, one mouse per line, terminated by end of file.

    The data for a particular mouse will consist of a pair of integers: the first representing its size in grams and the second representing its speed in centimeters per second. Both integers are between 1 and 10000. The data in each test case will contain information for at most 1000 mice.

    Two mice may have the same weight, the same speed, or even the same weight and speed. 
     
    Output
    Your program should output a sequence of lines of data; the first line should contain a number n; the remaining n lines should each contain a single positive integer (each one representing a mouse). If these n integers are m[1], m[2],..., m[n] then it must be the case that 

    W[m[1]] < W[m[2]] < ... < W[m[n]]

    and 

    S[m[1]] > S[m[2]] > ... > S[m[n]]

    In order for the answer to be correct, n should be as large as possible.
    All inequalities are strict: weights must be strictly increasing, and speeds must be strictly decreasing. There may be many correct outputs for a given input, your program only needs to find one. 
     
    Sample Input
    6008 1300 6000 2100 500 2000 1000 4000 1100 3000 6000 2000 8000 1400 6000 1200 2000 1900
     
    Sample Output
    4 4 5 9 7
     
    我的想法是先按一种属性排序,然后求最长上升子序列,再输出路径。
    #include <iostream>
    #include <cstdio>
    #include <cstring>
    #include <algorithm>
    using namespace std;
    #define max(a,b) a>b?a:b
    #define INF 0x7ffffff
    #define N 10010
    
    struct Mouse
    {
        int v,w,id; //v表示速度,w表示重量,id表示原来的位置
    }s[N];
    
    bool cmp(Mouse a,Mouse b)
    {
        return a.v>b.v; //按速度从大到小
    }
    
    int main()
    {
        int n=1;
        int dp[N]={0};
        while(scanf("%d%d",&s[n].w,&s[n].v)!=EOF)
        {
            s[n].id=n++;
        }
        n--;
        sort(s+1,s+n+1,cmp);
        int i,j,pre[N]={0};
        for(i=1;i<=n;i++)
        {
            for(j=i+1;j<=n;j++)
            {
                if(s[i].v>s[j].v && s[i].w<s[j].w) //满足题意
                {
                    if(dp[j]<dp[i]+1) //记录路径
                    {
                        dp[j]=dp[i]+1;
                        pre[j]=i;
                    }
                }
            }
        }
        int ans=-1,path[N],end,len=0;
        for(i=1;i<=n;i++)
        {
            if(ans<dp[i])
            {
                ans=dp[i];
                end=i;
            }
        }
        cout<<ans+1<<endl;
        for(i=end;i;i=pre[i])
        {
            path[++len]=s[i].id;
        }
        for(i=len;i>=1;i--)
        {
            cout<<path[i]<<endl;
        }
        return 0;
    }
    趁着还有梦想、将AC进行到底~~~by 452181625
  • 相关阅读:
    蓝桥杯训练 | 枚举,模拟与排序 | 04
    linux全套 | Linux模板机器安装 | 18
    linux全套 | Shell编程 | 16
    MySQL主从复制延迟解决方案
    MySQL异地备份方案
    MYSQL必知必会-where语句
    MySQL常见面试题-概念题
    入门-MySQL查询语句的45道练习
    20145234黄斐《信息安全系统设计基础》第0周学习总结
    OpenGL代码学习(2)
  • 原文地址:https://www.cnblogs.com/hate13/p/4050487.html
Copyright © 2011-2022 走看看