zoukankan      html  css  js  c++  java
  • hdu 1003

    Max Sum

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 82954    Accepted Submission(s): 19109


    Problem Description
    Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
     

     

    Input
    The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
     

     

    Output
    For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
     

     

    Sample Input
    2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
     

     

    Sample Output
    Case 1: 14 1 4 Case 2: 7 1 6

    #include<iostream>
    using namespace std;
    int
    a[100001];
    int
    main()
    {

        long
    n,max,sum,xi,x,y,k,m,i;
        //long long n,max,sum,xi,x,y,k,m,i;
        cin>>n;
        for
    (k=1;k<=n;k++)
        {

            cin>>m;
            max=-2;
            if
    (k!=1)  
                cout<<endl;
            for
    (i=0;i<m;i++)
                cin>>a[i];
            sum=-2;
            for
    (i=0;i<m;i++)
            {

                if
    (sum>=0)
                    sum+=a[i];
                else

                {

                    sum=a[i];
                    xi=i;
                }

                if
    (sum>=max)
                {

                    max=sum;
                    x=xi;
                    y=i;
                }
            }

            cout<<"Case "<<k<<':'<<endl;
            cout<<max<<' '<<x+1<<' '<<y+1<<endl;
        }

        return
    0;
    }

  • 相关阅读:
    HDU 2328 POJ 3450 KMP
    挨踢江湖之十八
    Solr4.2迁移到新项目下异常:java.lang.NoSuchMethodError: org.apache.http.conn.scheme.Scheme.<init>
    滚动条
    《取悦症》听书笔记
    《洞见远胜创意》听书笔记-如何获得洞见
    《乌合之众》听书笔记
    《巨人的工具》听书笔记
    程序员职业生涯规划
    2017第20周摘录
  • 原文地址:https://www.cnblogs.com/hduacm/p/2623372.html
Copyright © 2011-2022 走看看