zoukankan      html  css  js  c++  java
  • POJ3259:Wormholes(spfa判负环)

    Wormholes

    Time Limit: 2000MS   Memory Limit: 65536K
    Total Submissions: 68097   Accepted: 25374

    题目链接:http://poj.org/problem?id=3259

    Description:

    While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..NM (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

    As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

    To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

    Input:

    Line 1: A single integer, FF farm descriptions follow. 
    Line 1 of each farm: Three space-separated integers respectively: NM, and W 
    Lines 2..M+1 of each farm: Three space-separated numbers (SET) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path. 
    Lines M+2..M+W+1 of each farm: Three space-separated numbers (SET) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.

    Output:

    Lines 1..F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

    Sample Input:

    2
    3 3 1
    1 2 2
    1 3 4
    2 3 1
    3 1 3
    3 2 1
    1 2 3
    2 3 4
    3 1 8

    Sample Output:

    NO
    YES

    题意:

    给出一些双向边以及其对应花费,然后还有一些单向边,可以回到之前的时间。问最后能否从起点出发,回到起点的时候时间在出发之前。

    题解:

    对于时间通道建负边权就行了,然后跑spfa看有没得负环。

    代码如下:

    #include <cstdio>
    #include <cstring>
    #include <algorithm>
    #include <iostream>
    #include <queue>
    #define INF 0x3f3f3f3f
    using namespace std;
    typedef long long ll;
    const int N = 505,M = 2505;
    int T,n,m,w;
    int head[N],d[N],c[N],vis[N];
    struct Edge{
        int u,v,w,next;
    }e[M<<2];
    int tot;
    void adde(int u,int v,int w){
        e[tot].u=u;e[tot].v=v;e[tot].w=w;e[tot].next=head[u];head[u]=tot++;
    }
    int spfa(int s){
        queue <int> q;
        memset(d,INF,sizeof(d));
        memset(vis,0,sizeof(vis));memset(c,0,sizeof(c));
        q.push(s);vis[s]=1;d[s]=0;c[s]=1;
        while(!q.empty()){
            int u=q.front();q.pop();vis[u]=0;
            if(c[u]>n){
                return 1;
            }
            for(int i=head[u];i!=-1;i=e[i].next){
                int v=e[i].v;
                if(d[v]>d[u]+e[i].w){
                    d[v]=d[u]+e[i].w;
                    if(!vis[v]){
                        vis[v]=1;
                        q.push(v);
                        c[v]++;
                    }
                }
            }
        }
         return 0;
    }
    int main(){
        scanf("%d",&T);
        while(T--){
            scanf("%d%d%d",&n,&m,&w);
            memset(head,-1,sizeof(head));tot=0;
            for(int i=1;i<=m;i++){
                int u,v,c;
                scanf("%d%d%d",&u,&v,&c);
                adde(u,v,c);adde(v,u,c);
            }
            for(int i=1;i<=w;i++){
                int u,v,c;
                scanf("%d%d%d",&u,&v,&c);
                adde(u,v,-c);
            }
            int flag=0;
            if(spfa(1)) flag=1;
            if(flag) puts("YES");
            else puts("NO");
        }
        return 0;
    }
  • 相关阅读:
    BZOJ 2655: calc(拉格朗日插值)
    BZOJ 1485: [HNOI2009]有趣的数列(卡特兰数)
    [学习笔记] 关于组合数的一些总结
    CF 1076E Vasya and a Tree(线段树+树剖)
    CF 1082E Increasing Frequency(贪心)
    51nod 1149 Pi的递推式(组合数学)
    LOJ 2743(洛谷 4365) 「九省联考 2018」秘密袭击——整体DP+插值思想
    关于 unsigned int 比较大小
    洛谷 3295 [SCOI2016]萌萌哒——并查集优化连边
    洛谷 P4512 [模板] 多项式除法
  • 原文地址:https://www.cnblogs.com/heyuhhh/p/10352102.html
Copyright © 2011-2022 走看看