zoukankan      html  css  js  c++  java
  • HDU 1005(周期问题)

                                        HDU 1005

    Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u
     

    Description

    A number sequence is defined as follows: 

    f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7. 

    Given A, B, and n, you are to calculate the value of f(n). 
     

    Input

    The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed. 
     

    Output

    For each test case, print the value of f(n) on a single line. 
     

    Sample Input

    1 1 3 1 2 10 0 0 0
     

    Sample Output

    2 5
     
    题解:

    一开始看到这题我就直接跳过了。。

    但是后来发现还是有些规律的,对于f[n-1] 或者 f[n-2] 的取值只有 0,1,2,3,4,5,6 这7个数,A,B又是固定的,所以就只有49种可能值了。由该关系式得知每一项只与前两项发生关系,所以当连续的两项在前面出现过循环节出现了,注意循环节并不一定会是开始的 1,1 。 又因为一组测试数据中f[n]只有49中可能的答案,最坏的情况是所有的情况都遇到了,那么那也会在50次运算中产生循环节。找到循环节后,就可以解决此题

    注意:周期的大小,有可能是大周期,有可能是小周期!

    #include<iostream>
    using namespace std;
    int f[54]={0,1,1};
    int main()
    {
        int A,B,n,q=1;
    while(cin>>A>>B>>n&&A&&B&&n)
    {
        for(int i=3;i<54;++i)
    {
        f[i]=(A*f[i-1]+B*f[i-2])% 7;
        if(i>4)
    {if(f[i-1]==f[3]&&f[i]==f[4])
        {
           q=i-4;  //要特别注意,可以想一下为什么?
    
        }
    }
        }
    cout<<f[n%q]<<endl;
    
    }
    
    return 0;
    }
     
  • 相关阅读:
    java基础—面向对象2
    java基础—java读取properties文件
    java基础—super关键字
    java基础—this关键字
    java基础—object类
    java基础—equals方法
    java基础—哈希编码
    Struct2(五)处理表单
    struct2(四)编写Struct2 的Action
    Struct2(三) Struct2 标签
  • 原文地址:https://www.cnblogs.com/hfc-xx/p/4655568.html
Copyright © 2011-2022 走看看