zoukankan      html  css  js  c++  java
  • HDU-1069 Monkey and Banana ( DP )

    Problem Description
    A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food.

    The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height.

    They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked.

    Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks.
     
    Input
    The input file will contain one or more test cases. The first line of each test case contains an integer n,
    representing the number of different blocks in the following data set. The maximum value for n is 30.
    Each of the next n lines contains three integers representing the values xi, yi and zi.
    Input is terminated by a value of zero (0) for n.
     
    Output
    For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case: maximum height = height".
     
    Sample Input
    1
    10 20 30
    2
    6 8 10
    5 5 5
    7
    1 1 1
    2 2 2
    3 3 3
    4 4 4
    5 5 5
    6 6 6
    7 7 7
    5
    31 41 59
    26 53 58
    97 93 23
    84 62 64
    33 83 27
    0
     
    Sample Output
    Case 1: maximum height = 40
    Case 2: maximum height = 21
    Case 3: maximum height = 28
    Case 4: maximum height = 342
     
    基础DP 由于每个立方体有三种摆法,所以在输入数据是要储存每个立方体的三种形式。然后对长进行排序(存储时使长大于宽),则问题就变成了求使高的和最大的宽递减的排列,即基础DP。
     
    #include<iostream>
    #include<cstring>
    #include<algorithm>
    #include<cmath>
    using namespace std;
    
    class Block{
    public:
        int x, y, z;
    }block[100];
    
    bool cmp( Block a, Block b ){
        if( a.x > b.x ) return true;
        else if( a.x == b.x && a.y > b.y ) return true;
        return false;
    }
    
    int dp[100];
    
    int main(){
        ios::sync_with_stdio( false );
    
        int n, tempx, tempy, tempz, sum = 1;
        while( cin >> n, n ){
            for( int i = 0; i < n; i++ ){
                cin >> tempx >> tempy >> tempz;
                block[i * 3 + 1].x = max( tempx, tempy ); block[i * 3 + 1].y = min( tempx, tempy ); block[i * 3 + 1].z = tempz;
                block[i * 3 + 2].x = max( tempy, tempz ); block[i * 3 + 2].y = min( tempy, tempz ); block[i * 3 + 2].z = tempx;
                block[i * 3 + 3].x = max( tempx, tempz ); block[i * 3 + 3].y = min( tempx, tempz ); block[i * 3 + 3].z = tempy;
            }
    
            sort( block + 1, block + n * 3 + 1, cmp );
            memset( dp, 0, sizeof( dp ) );
    
            int ans = 0;
            for( int i = 1; i <= 3 * n; i++ ){
                for( int j = 1; j < i; j++ )
                    if( block[i].x < block[j].x && block[i].y < block[j].y ){
                        dp[i] = max( dp[i], dp[j] );
                    }
    
                dp[i] += block[i].z;
                ans = max( ans, dp[i] );
            }
    
            cout << "Case " << sum++ << ": maximum height = " << ans << endl;
        }
    
        return 0;
    }
  • 相关阅读:
    网络安全系列 之 MySQL数据库安全
    设计模式 之 责任链模式学习实践
    清晰化算法在DSP上的实现
    图像清晰化 之雾天图像清晰化处理
    Jupyter Notebook
    网络安全系列 之 协议安全
    FTP、FTPS、SFTP概览
    ImportError: Imageio Pillow plugin requires Pillow, not PIL!
    ubuntu 下开机启动项修复(进不去windows系统)
    error while loading shared libraries: libopencv_core.so.3.4: cannot open shared object file: No such file or directory
  • 原文地址:https://www.cnblogs.com/hollowstory/p/5436125.html
Copyright © 2011-2022 走看看