zoukankan      html  css  js  c++  java
  • HDU 1085 Holding BinLaden Captive!

    Holding Bin-Laden Captive!

    We all know that Bin-Laden is a notorious terrorist, and he has disappeared for a long time. But recently, it is reported that he hides in Hang Zhou of China! 
    “Oh, God! How terrible! ”

    Don’t be so afraid, guys. Although he hides in a cave of Hang Zhou, he dares not to go out. Laden is so bored recent years that he fling himself into some math problems, and he said that if anyone can solve his problem, he will give himself up! 
    Ha-ha! Obviously, Laden is too proud of his intelligence! But, what is his problem?
    “Given some Chinese Coins (硬币) (three kinds-- 1, 2, 5), and their number is num_1, num_2 and num_5 respectively, please output the minimum value that you cannot pay with given coins.”
    You, super ACMer, should solve the problem easily, and don’t forget to take $25000000 from Bush!

     
    Input
    Input contains multiple test cases. Each test case contains 3 positive integers num_1, num_2 and num_5 (0<=num_i<=1000). A test case containing 0 0 0 terminates the input and this test case is not to be processed.
     
    Output
    Output the minimum positive value that one cannot pay with given coins, one line for one case.
     
    Sample Input
    1 1 3 0 0 0
     
    Sample Output
    4

    解:母函数求解

    #include<iostream>
    using namespace std;
    #include<string.h>
    int c1[10000],c2[10000];
    int main()
    {
        int c[3];
        int i,j,k,k1,m;    
        while(scanf("%d%d%d",&c[0],&c[1],&c[2])!=EOF&&(c[0]||c[1]||c[2]))
        {
            m=c[0]*1+c[1]*2+c[2]*5;
            memset(c1,0,sizeof(c1));
            memset(c2,0,sizeof(c2));
            for(i=0;i<=c[0];i++)
            {
                c1[i]=1;
            }
           for(j=0;j<=m;j++)
            for(k=0,k1=0;k+j<=m&&k1<=c[1];k+=2,k1++)
            {
                c2[k+j]+=c1[j];    
            }
            for(j=0;j<=m;j++)
             {
                 c1[j]=c2[j];
                 c2[j]=0;
             }
            for(j=0;j<=m;j++)
             for(k=0,k1=0;k+j<=m&&k1<=c[2];k+=5,k1++)
             {
                 c2[k+j]+=c1[j];
             }
            for(j=0;j<=m;j++)
             {
                 c1[j]=c2[j];
             }
            for(j=0;j<=m;j++)
            {
                if(c1[j]==0)
                {
                 printf("%d\n",j);
                 break;
                }
            }
            if(j==m+1)
            printf("%d\n",j);
        }//while
            
        return 0;
    }
  • 相关阅读:
    Markdown学习笔记
    带下划线点域名解析失败
    前端工程师学习之路
    Java 调用 WebService 客户端代码 含通过代理调用
    MySQL 日期函数 时间函数 总结 (MySQL 5_X)
    Apache、Tomcat整合环境搭建
    201671010142 <java程序设计>初次学习心得与感悟
    201671010142 Java基本程序设计结构学习的感悟
    201671010142.第五章的学习总结
    201671010142 继承定义与使用 感悟与总结
  • 原文地址:https://www.cnblogs.com/hsqdboke/p/2455835.html
Copyright © 2011-2022 走看看