zoukankan      html  css  js  c++  java
  • Bellovin_树状数组

    Problem Description
    Peter has a sequence a1,a2,...,an and he define a function on the sequence -- F(a1,a2,...,an)=(f1,f2,...,fn), where fi is the length of the longest increasing subsequence ending with ai.

    Peter would like to find another sequence b1,b2,...,bn in such a manner that F(a1,a2,...,an) equals to F(b1,b2,...,bn). Among all the possible sequences consisting of only positive integers, Peter wants the lexicographically smallest one.

    The sequence a1,a2,...,an is lexicographically smaller than sequence b1,b2,...,bn, if there is such number i from 1 to n, that ak=bk for 1k<i and ai<bi.
     
    Input
    There are multiple test cases. The first line of input contains an integer T, indicating the number of test cases. For each test case:

    The first contains an integer n (1n100000) -- the length of the sequence. The second line contains n integers a1,a2,...,an (1ai109).
     
    Output
    For each test case, output n integers b1,b2,...,bn (1bi109) denoting the lexicographically smallest sequence.
     
    Sample Input
    3 1 10 5 5 4 3 2 1 3 1 3 5
     
    Sample Output
    1 1 1 1 1 1 1 2 3

    【题意】给出n个数的序列求每个数的最长上升子序列

    【思路】可以树状数组求解

    #include<iostream>
    #include<stdio.h>
    #include<string.h>
    #include<algorithm>
    using namespace std;
    const int N=100000+10;
    int a[N],b[N],c[N],ans[N];
    int n,cnt;
    int lowbit(int x)
    {
        return x&(-x);
    }
    
    int query(int x)
    {
        int res=0;
        while(x)
        {
            res=max(c[x],res);//找出前面比他小的数中拥有最长上升子序列的
            x-=lowbit(x);
        }
        return res;
    }
    void update(int p,int x)
    {
        while(p<=cnt)
        {
            c[p]=max(x,c[p]);//把后面的数最长上升子序列进行更新
            p+=lowbit(p);
        }
    }
    
    int main()
    {
        int t;
        scanf("%d",&t);
        while(t--)
        {
            scanf("%d",&n);
            for(int i=1;i<=n;i++)
            {
                scanf("%d",&a[i]);
                b[i]=a[i];
            }
            sort(b+1,b+1+n);
            cnt=unique(b+1,b+1+n)-b-1;
            for(int i=1;i<=n;i++)
            {
                a[i]=lower_bound(b+1,b+1+cnt,a[i])-b;
            }
            memset(c,0,sizeof(c));
            for(int i=1;i<=n;i++)
            {
                ans[i]=query(a[i]-1)+1;//前面存在的最长上升子序列长度加上1,就是当前数拥有的最长上升子序列长度
                update(a[i],ans[i]);//更新后面的数的长度
                printf("%d%c",ans[i],i==n?'
    ':' ');
            }
        }
    
        return 0;
    }
  • 相关阅读:
    CentOS7.4安装Docker
    责任链模式
    策略模式
    状态模式
    解释器模式
    备忘录模式
    中介者模式
    观察者模式
    迭代器模式
    private、default、protected和public的作用域
  • 原文地址:https://www.cnblogs.com/iwantstrong/p/6081468.html
Copyright © 2011-2022 走看看