zoukankan      html  css  js  c++  java
  • POJ 3087 Shuffle'm Up

    Shuffle'm Up

    Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 131072/65536K (Java/Other)

    Total Submission(s) : 41   Accepted Submission(s) : 23

    Problem Description

    A common pastime for poker players at a poker table is to shuffle stacks of chips. Shuffling chips is performed by starting with two stacks of poker chips, S1 and S2, each stack containing C chips. Each stack may contain chips of several different colors.

    The actual shuffle operation is performed by interleaving a chip from S1 with a chip from S2 as shown below for C = 5:

    The single resultant stack, S12, contains 2 * C chips. The bottommost chip of S12 is the bottommost chip from S2. On top of that chip, is the bottommost chip from S1. The interleaving process continues taking the 2nd chip from the bottom of S2 and placing that on S12, followed by the 2nd chip from the bottom of S1 and so on until the topmost chip from S1 is placed on top of S12.

    After the shuffle operation, S12 is split into 2 new stacks by taking the bottommost C chips from S12 to form a new S1 and the topmost C chips from S12 to form a new S2. The shuffle operation may then be repeated to form a new S12.

    For this problem, you will write a program to determine if a particular resultant stack S12 can be formed by shuffling two stacks some number of times.

     
    Input

    The first line of input contains a single integer N, (1 ≤ N ≤ 1000) which is the number of datasets that follow.

    Each dataset consists of four lines of input. The first line of a dataset specifies an integer C, (1 ≤ C ≤ 100) which is the number of chips in each initial stack (S1 and S2). The second line of each dataset specifies the colors of each of the C chips in stack S1, starting with the bottommost chip. The third line of each dataset specifies the colors of each of the C chips in stack S2 starting with the bottommost chip. Colors are expressed as a single uppercase letter (A through H). There are no blanks or separators between the chip colors. The fourth line of each dataset contains 2 * C uppercase letters (A through H), representing the colors of the desired result of the shuffling of S1 and S2 zero or more times. The bottommost chip’s color is specified first.

     
    Output

    Output for each dataset consists of a single line that displays the dataset number (1 though N), a space, and an integer value which is the minimum number of shuffle operations required to get the desired resultant stack. If the desired result can not be reached using the input for the dataset, display the value negative 1 (−1) for the number of shuffle operations.

     
    Sample Input
    2
    4
    AHAH
    HAHA
    HHAAAAHH
    3
    CDE
    CDE
    EEDDCC
     
    Sample Output
    1 2
    2 -1
     
    Source
    PKU
     
     
     
    说明:简单的洗牌,,,用map实用
     
    #include<iostream>
    #include<vector>
    #include<map>
    #include<cstdio>
    #include<cstring>
    
    using namespace std;
    
    vector<char> vs,vsTarget;
    map<vector<char>,int> vimap;
    
    void shuffle(int C){
        vector<char> vtmp(vs);
        int i;
        for(i=0;i<2*C;i++)
            if(i%2==0)
                vs[i]=vtmp[C+i/2];
            else
                vs[i]=vtmp[i/2];
    }
    
    int main(){
        int n;
        scanf("%d",&n);
        int i,j;
        for(i=1;i<=n;i++){
            vs.clear();
            vsTarget.clear();
            int C;
            char ch;
            scanf("%d",&C);
            for(j=0;j<2*C;j++){
                cin>>ch;
                vs.push_back(ch);
            }
            for(j=0;j<2*C;j++){
                cin>>ch;
                vsTarget.push_back(ch);
            }
            int times=0;
            while(++times){
                shuffle(C);
                if(vs==vsTarget){
                    printf("%d %d\n",i,times);
                    break;
                }
                if(vimap[vs]==0)
                    vimap[vs]=1;
                else{
                    printf("%d -1\n",i);
                    break;
                }
            }
        }
        return 0;
    }

    DFS搜索:

    #include<stdio.h>
    #include<string.h>
    
    int n;
    char a[105],b[105],target[205],tmp[205];
    int ans;
    
    int DFS(int x){
        if(x>10000){
            ans=-1;
            return 0;
        }
        if(ans)
            return 0;
        int i;
        for(i=0;i<2*n;i++){
            tmp[2*i]=b[i];
            tmp[2*i+1]=a[i];
        }
        for(i=0;i<n;i++){
            a[i]=tmp[i];
            b[i]=tmp[n+i];
        }
        if(strcmp(tmp,target)==0){
            ans=x;
            return 0;
        }
        DFS(x+1);
        return 0;
    }
    
    int main(){
        int t;
        scanf("%d",&t);
        int i;
        for(i=1;i<=t;i++){
            scanf("%d",&n);
            getchar();
            scanf("%s",a);
            scanf("%s",b);
            scanf("%s",target);
            ans=0;
            DFS(1);
            printf("%d %d\n", i, ans);
        }
        return 0;
    }
  • 相关阅读:
    智能安全实验室-全能优化(Guardio) 3.8.0.493:系统默认字体大小
    智能安全实验室-杀马(Defendio) 2.6.0.453 :系统整合/增强隔离
    智能安全实验室-全能优化(Guardio) 3.8.0.498:新增3种恶意软件的清理
    智能安全实验室-杀马(Defendio) 2.5.0.425-自定义快捷方式
    智能安全实验室-全能优化(Guardio) 3.9.0.523:大量改进!
    智能安全实验室-全能优化(Guardio) 3.9.0.525:进程管理树状显示
    智能安全实验室-杀马(Defendio) 2.5.0.435 :改进系统扫描
    智能安全实验室-全能优化(Guardio) 3.8.0.495:新增15种恶意软件的清理
    智能安全实验室-杀马(Defendio) 2.6.0.466 :行为分析
    智能安全实验室-杀马(Defendio) 2.5.0.430 :自定义上报威胁
  • 原文地址:https://www.cnblogs.com/jackge/p/2829783.html
Copyright © 2011-2022 走看看