zoukankan      html  css  js  c++  java
  • HDU 1372 Knight Moves

    Knight Moves

    http://acm.hdu.edu.cn/showproblem.php?pid=1372

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 3908    Accepted Submission(s): 2432

    Problem Description
    A friend of you is doing research on the Traveling Knight Problem (TKP) where you are to find the shortest closed tour of knight moves that visits each square of a given set of n squares on a chessboard exactly once. He thinks that the most difficult part of the problem is determining the smallest number of knight moves between two given squares and that, once you have accomplished this, finding the tour would be easy. Of course you know that it is vice versa. So you offer him to write a program that solves the "difficult" part.
    Your job is to write a program that takes two squares a and b as input and then determines the number of knight moves on a shortest route from a to b.
     
    Input
    The input file will contain one or more test cases. Each test case consists of one line containing two squares separated by one space. A square is a string consisting of a letter (a-h) representing the column and a digit (1-8) representing the row on the chessboard.
     
    Output
    For each test case, print one line saying "To get from xx to yy takes n knight moves.".
     
    Sample Input
     
    e2 e4
    a1 b2
    b2 c3
    a1 h8
    a1 h7
    h8 a1
    b1 c3
    f6 f6
     
    Sample Output
     
    To get from e2 to e4 takes 2 knight moves.
    To get from a1 to b2 takes 4 knight moves.
    To get from b2 to c3 takes 2 knight moves.
    To get from a1 to h8 takes 6 knight moves.
    To get from a1 to h7 takes 5 knight moves.
    To get from h8 to a1 takes 6 knight moves.
    To get from b1 to c3 takes 1 knight moves.
    To get from f6 to f6 takes 0 knight moves.
     
    Source
     
     
    解法一: DFS搜索
     
    #include<stdio.h>
    
    char s[5],t[5];
    int map[8][8];
    
    int dir[8][2]={{1,2},{2,1},{2,-1},{1,-2},{-1,-2},{-2,-1},{-2,1},{-1,2}};
    
    void DFS(int x,int y,int step){
        if(x<0 || x>7 || y<0 || y>7 || step>map[x][y])
            return ;
        map[x][y]=step;
        for(int i=0;i<8;i++)
            DFS(x+dir[i][0],y+dir[i][1],step+1);
    }
    
    int main(){
        while(scanf("%s%s",s,t)!=EOF){
            for(int i=0;i<8;i++)
                for(int j=0;j<8;j++)
                    map[i][j]=10;
            DFS(s[0]-'a',s[1]-'1',0);
            printf("To get from %s to %s takes %d knight moves.\n",s,t,map[t[0]-'a'][t[1]-'1']);
        }
        return 0;
    }

    解法二:BFS搜索

    #include<iostream>
    #include<queue>
    #include<cstdio>
    #include<cstring>
    
    using namespace std;
    
    struct node{
        int x,y;
        int step;
    };
    
    char s[5],t[5];
    int vis[10][10],ans;
    
    int dir[8][2]={{1,2},{2,1},{2,-1},{1,-2},{-1,-2},{-2,-1},{-2,1},{-1,2}};
    
    int BFS(){
        queue<node> q;
        while(!q.empty())
            q.pop();
        node cur,next;
        cur.x=s[0]-'a'+1;cur.y=s[1]-'0';cur.step=0;
        vis[cur.x][cur.y]=1;
        q.push(cur);
        while(!q.empty()){
            cur=q.front();
            q.pop();
            for(int i=0;i<8;i++){
                next.x=cur.x+dir[i][0];
                next.y=cur.y+dir[i][1];
                next.step=cur.step+1;
                if(next.x<1 || next.x>8 || next.y<1 || next.y>8)
                    continue;
                if(next.x==t[0]-'a'+1 && next.y==t[1]-'0')
                    return next.step;
                if(!vis[next.x][next.y]){
                    vis[next.x][next.y]=1;
                    q.push(next);
                }
            }
        }
        return 0;
    }
    
    int main(){
    
        //freopen("input.txt","r",stdin);
    
        while(~scanf("%s%s",s,t)){
            memset(vis,0,sizeof(vis));
            if(strcmp(s,t)==0)
                ans=0;
            else
                ans=BFS();
            printf("To get from %s to %s takes %d knight moves.\n",s,t,ans);
        }
        return 0;
    }
  • 相关阅读:
    透视分析
    仪表分析
    sql查询和预览界面,在预览界面选择图表最后进行导出数据和图表到excel
    可视化查询
    创建数据源
    Smartbi使用Oracle RAC数据库做知识库
    反应器(Reactor)模式
    Netty:EventLoopGroup
    ShuffleTest java 使用集合的方式进行排序
    MapTest java 核心编程
  • 原文地址:https://www.cnblogs.com/jackge/p/2853204.html
Copyright © 2011-2022 走看看