zoukankan      html  css  js  c++  java
  • POJ 2318 TOYS

    TOYS
    Time Limit: 2000MS   Memory Limit: 65536K
    Total Submissions: 8275   Accepted: 3922

    Description

    Calculate the number of toys that land in each bin of a partitioned toy box. 
    Mom and dad have a problem - their child John never puts his toys away when he is finished playing with them. They gave John a rectangular box to put his toys in, but John is rebellious and obeys his parents by simply throwing his toys into the box. All the toys get mixed up, and it is impossible for John to find his favorite toys. 

    John's parents came up with the following idea. They put cardboard partitions into the box. Even if John keeps throwing his toys into the box, at least toys that get thrown into different bins stay separated. The following diagram shows a top view of an example toy box. 
     
    For this problem, you are asked to determine how many toys fall into each partition as John throws them into the toy box.

    Input

    The input file contains one or more problems. The first line of a problem consists of six integers, n m x1 y1 x2 y2. The number of cardboard partitions is n (0 < n <= 5000) and the number of toys is m (0 < m <= 5000). The coordinates of the upper-left corner and the lower-right corner of the box are (x1,y1) and (x2,y2), respectively. The following n lines contain two integers per line, Ui Li, indicating that the ends of the i-th cardboard partition is at the coordinates (Ui,y1) and (Li,y2). You may assume that the cardboard partitions do not intersect each other and that they are specified in sorted order from left to right. The next m lines contain two integers per line, Xj Yj specifying where the j-th toy has landed in the box. The order of the toy locations is random. You may assume that no toy will land exactly on a cardboard partition or outside the boundary of the box. The input is terminated by a line consisting of a single 0.

    Output

    The output for each problem will be one line for each separate bin in the toy box. For each bin, print its bin number, followed by a colon and one space, followed by the number of toys thrown into that bin. Bins are numbered from 0 (the leftmost bin) to n (the rightmost bin). Separate the output of different problems by a single blank line.

    Sample Input

    5 6 0 10 60 0
    3 1
    4 3
    6 8
    10 10
    15 30
    1 5
    2 1
    2 8
    5 5
    40 10
    7 9
    4 10 0 10 100 0
    20 20
    40 40
    60 60
    80 80
     5 10
    15 10
    25 10
    35 10
    45 10
    55 10
    65 10
    75 10
    85 10
    95 10
    0
    

    Sample Output

    0: 2
    1: 1
    2: 1
    3: 1
    4: 0
    5: 1
    
    0: 2
    1: 2
    2: 2
    3: 2
    4: 2
    

    Hint

    As the example illustrates, toys that fall on the boundary of the box are "in" the box.

    Source

     
     
     
    #include<iostream>
    #include<cstdio>
    #include<cstring>
    #include<cmath>
    
    using namespace std;
    
    struct point{
        long long x,y;
    };
    
    long long xmult(point &a,point &b,point &c){
        return (a.x-c.x)*(b.y-c.y)-(b.x-c.x)*(a.y-c.y);
    }
    
    struct line{
        point a,b;
    }l[5010];
    
    int n,m;
    int counts[5010];
    long long X1,Y1,X2,Y2;
    
    int binarySearch(point &p){
        int low=0,high=n,mid;
        while(low<=high){
            mid=(low+high)>>1;
            if(xmult(l[mid].a,l[mid].b,p)>0)
                low=mid+1;
            else
                high=mid-1;
        }
        return high+1;
    }
    
    int main(){
    
        //freopen("input.txt","r",stdin);
    
        int flag=1;
        while(cin>>n && n){
            if(!flag)
                cout<<endl;
            flag=0;
            cin>>m>>X1>>Y1>>X2>>Y2;
            memset(counts,0,sizeof(counts));
            for(int i=0;i<n;i++){
                cin>>l[i].a.x>>l[i].b.x;
                l[i].a.y=Y1;
                l[i].b.y=Y2;
            }
            l[n].a.x=X2;
            l[n].a.y=Y1;
            l[n].b.x=X2;
            l[n].b.y=Y2;
    
            point toy;
            for(int i=0;i<m;i++){
                cin>>toy.x>>toy.y;
                int j=binarySearch(toy);
                counts[j]++;
            }
            for(int i=0;i<=n;i++)
                cout<<i<<": "<<counts[i]<<endl;
        }
        return 0;
    }
  • 相关阅读:
    unity, 显示像素图,以及iOS下像素图变模糊解决办法
    unity, iOS集成微信
    unity, PlayerPrefs.GetInt(key,defaultValue)
    unity, 对于Debug.Log输出的log,可以双击定位到代码
    unity, UGUI Image shader
    unity, use particleSystem with UGUI
    unity, UGUI Text fadeIn
    unity, write/read txt file
    unity, get Canvas Scaler referenceResolution
    unity, change parent and keep localPosition or worlPosition
  • 原文地址:https://www.cnblogs.com/jackge/p/2952310.html
Copyright © 2011-2022 走看看