zoukankan      html  css  js  c++  java
  • HDU What Are You Talking About

    What Are You Talking About

    Time Limit : 10000/5000ms (Java/Other)   Memory Limit : 102400/204800K (Java/Other)
    Total Submission(s) : 13   Accepted Submission(s) : 8

    Font: Times New Roman | Verdana | Georgia

    Font Size:  

    Problem Description

    Ignatius is so lucky that he met a Martian yesterday. But he didn't know the language the Martians use. The Martian gives him a history book of Mars and a dictionary when it leaves. Now Ignatius want to translate the history book into English. Can you help him?

    Input

    The problem has only one test case, the test case consists of two parts, the dictionary part and the book part. The dictionary part starts with a single line contains a string "START", this string should be ignored, then some lines follow, each line contains two strings, the first one is a word in English, the second one is the corresponding word in Martian's language. A line with a single string "END" indicates the end of the directory part, and this string should be ignored. The book part starts with a single line contains a string "START", this string should be ignored, then an article written in Martian's language. You should translate the article into English with the dictionary. If you find the word in the dictionary you should translate it and write the new word into your translation, if you can't find the word in the dictionary you do not have to translate it, and just copy the old word to your translation. Space(' '), tab('\t'), enter('\n') and all the punctuation should not be translated. A line with a single string "END" indicates the end of the book part, and that's also the end of the input. All the words are in the lowercase, and each word will contain at most 10 characters, and each line will contain at most 3000 characters.

    Output

    In this problem, you have to output the translation of the history book.

    Sample Input

    START
    from fiwo
    hello difh
    mars riwosf
    earth fnnvk
    like fiiwj
    END
    START
    difh, i'm fiwo riwosf.
    i fiiwj fnnvk!
    END
    

    Sample Output

    hello, i'm from mars.
    i like earth!
    

    Hint

    Huge input, scanf is recommended.

    Author

    Ignatius.L
     
     该代码存在问题,如果只输入 r 这个字符,则问题就出来了
     
     
    #include<iostream>
    #include<cstdio>
    #include<cstring>
    
    using namespace std;
    
    struct Trie{
        char wrd[20];
        int flag;
        Trie *next[26];
        Trie(){
            for(int i=0;i<26;i++)
                next[i]=NULL;
            flag=0;
        }
    };
    
    Trie *root;
    
    char s[3100];
    
    void InsertTrie(char *str,char *wrd){
        Trie *loc=root,*tmp;
        for(int i=0;str[i]!='\0';i++){
            int id=str[i]-'a';
            if(loc->next[id]==NULL){
                tmp=new Trie();
                loc->next[id]=tmp;
            }
            loc=loc->next[id];
        }
        loc->flag=1;
        strcpy(loc->wrd,wrd);
    }
    
    int SearchTrie(char *str,char *wrd){
        Trie *loc=root;
        for(int i=0;str[i]!='\0';i++){
            int id=str[i]-'a';
            if(loc->next[id]!=NULL)
                loc=loc->next[id];
            else
                return 0;
        }
        if(loc->flag){
            strcpy(wrd,loc->wrd);
            return 1;
        }
        return 0;
    }
    
    void release(Trie *rt){
        if(rt==NULL)
            return ;
        for(int i=0;i<26;i++)
            if(rt->next[i]!=NULL)
                release(rt->next[i]);
        delete rt;
        rt=NULL;
    }
    
    int main(){
    
        //freopen("input.txt","r",stdin);
    
        root=new Trie();
        char str[20],wrd[20];
        gets(s);
        while(gets(s) && s[0]!='E'){
            sscanf(s,"%s%s",wrd,str);
            InsertTrie(str,wrd);
        }
        gets(s);
        int cnt,len;
        while(gets(s) && s[0]!='E'){
            len=strlen(s);
            cnt=0;
            for(int i=0;i<len;i++){
                if(s[i]>='a' && s[i]<='z')
                    str[cnt++]=s[i];
                else{
                    str[cnt]='\0';
                    if(cnt>0){
                        if(SearchTrie(str,wrd))
                            printf("%s",wrd);
                        else
                            printf("%s",str);
                    }
                    printf("%c",s[i]);
                    cnt=0;
                }
            }
            str[cnt]='\0';
            if(cnt>0){
                if(SearchTrie(str,wrd))
                    printf("%s",wrd);
                else
                    printf("%s",str);
            }
            printf("\n");
        }
        //release(root);  空间够用就别加,还浪费时间
        return 0;
    }

  • 相关阅读:
    [转]资本经营董事长班告诉你:不只企业有商业模式,个人商业价值更重要
    [转]把人当成一个公司来经营,心就不会那么累
    [转]东方财智商学院告诉你如何写成功的商业计划书,按这23点来就好了
    [转]《穷爸爸富爸爸》作者破产了,他捧红了“财务自由”
    [转]人人店短信插件开发
    [转]简单的动态修改RDLC报表页边距和列宽的方法
    [转]程序员应打破牢笼,展望更高层次的世界
    jQuery validate and groups
    [转]C#利用反射实现两个类的对象之间相同属性的值的复制
    [转]ui-grid User can't select the row by clicking the select checkbox available in the respective row when enableFullRowSelection : true"
  • 原文地址:https://www.cnblogs.com/jackge/p/2991945.html
Copyright © 2011-2022 走看看