zoukankan      html  css  js  c++  java
  • HDU 2899 Strange fuction (二分)

    Strange fuction

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 1840    Accepted Submission(s): 1364


    Problem Description
    Now, here is a fuction:
      F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-y*x (0 <= x <=100)
    Can you find the minimum value when x is between 0 and 100.
     
    Input
    The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has only one real numbers Y.(0 < Y <1e10)
     
    Output
    Just the minimum value (accurate up to 4 decimal places),when x is between 0 and 100.
     
    Sample Input
    2
    100
     
    200
     
    Sample Output
    -74.4291
    -178.8534
     
    Author
    Redow
     
    Recommend
    lcy
     
    分析:
    求函数的最小值,首先求导的导函数为:G(x) = 42 * x^6+48*x^5+21*x^2+10*x-y (0 <= x <=100)
    分析导函数的,导函数为一个单调递增的函数。如果导函数的最大值小于0,那么原函数在区间内单调递减。
    即F(100)最小;如果但函数的最小值大于0,那么原函数在区间内单调递增,即F(0)最小。如果导函数既有正又有负
    又由于导函数是单增函数,所以必有先负后正,即原函数必有先减后增的性质。求出导函数的零点就是原函数的最小值点。
    求导函数最小值方法是2分法.



    #include<iostream>
    #include<cstdio>
    #include<cmath>
    
    using namespace std;
    
    #define eps 1e-10
    
    double y;
    
    double g(double x){
        return 42*pow(x,6)+48*pow(x,5)+21*pow(x,2)+10*x;
    }
    
    double f(double x){
        return 6*pow(x,7)+8*pow(x,6)+7*pow(x,3)+5*pow(x,2)-y*x;;
    }
    
    int main(){
    
        //freopen("input.txt","r",stdin);
    
        int t;
        double left,right,mid;
        scanf("%d",&t);
        while(t--){
            scanf("%lf",&y);
            if(g(100.0)-y<=0){
                printf("%.4lf\n",f(100.0));
                continue;
            }
            left=0;
            right=100;
            while(right-left>=eps){
                mid=(right+left)/2;
                if(g(mid)-y<eps)
                    left=mid;
                else
                    right=mid;
            }
            printf("%.4lf\n",f(mid));
        }
        return 0;
    }
  • 相关阅读:
    屠蛟之路_重伤的屠蛟俊_ThirdDay
    屠蛟之路_重登数据库大山_SecondDay
    屠蛟之路_你的名字_FirstDay
    Beta版本冲刺计划及安排
    软件工程作业1203
    导师互选系统 Alpha版冲刺总结
    屠龙之路_项目测试
    【Alpha】十天屠龙记
    屠龙之路_冲刺总结随笔
    My97日历控件常用功能记录
  • 原文地址:https://www.cnblogs.com/jackge/p/3029773.html
Copyright © 2011-2022 走看看