zoukankan      html  css  js  c++  java
  • POJ 1144 Network (割点,两种模板)

    Network
    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 7510   Accepted: 3525

    Description

    A Telephone Line Company (TLC) is establishing a new telephone cable network. They are connecting several places numbered by integers from 1 to N . No two places have the same number. The lines are bidirectional and always connect together two places and in each place the lines end in a telephone exchange. There is one telephone exchange in each place. From each place it is 
    possible to reach through lines every other place, however it need not be a direct connection, it can go through several exchanges. From time to time the power supply fails at a place and then the exchange does not operate. The officials from TLC realized that in such a case it can happen that besides the fact that the place with the failure is unreachable, this can also cause that some other places cannot connect to each other. In such a case we will say the place (where the failure 
    occured) is critical. Now the officials are trying to write a program for finding the number of all such critical places. Help them.

    Input

    The input file consists of several blocks of lines. Each block describes one network. In the first line of each block there is the number of places N < 100. Each of the next at most N lines contains the number of a place followed by the numbers of some places to which there is a direct line from this place. These at most N lines completely describe the network, i.e., each direct connection of two places in the network is contained at least in one row. All numbers in one line are separated 
    by one space. Each block ends with a line containing just 0. The last block has only one line with N = 0;

    Output

    The output contains for each block except the last in the input file one line containing the number of critical places.

    Sample Input

    5
    5 1 2 3 4
    0
    6
    2 1 3
    5 4 6 2
    0
    0

    Sample Output

    1
    2

    Hint

    You need to determine the end of one line.In order to make it's easy to determine,there are no extra blank before the end of each line.

    Source

    题意:就要给你一个图,求有多少个割点

    思路:求无向图的割点,直接上模板没什么好说的,附上两种形式的模板

    #include<iostream>
    #include<cstdio>
    #include<cstring>
    
    using namespace std;
    
    const int N=110;
    
    int dfn[N],low[N],head[N],vis[N];
    bool cut[N];
    int k,n,cnt,root;
    
    struct Edge{
        int to,nxt;
    }edge[N<<1];
    
    void addedge(int cu,int cv){
        edge[cnt].to=cv;
        edge[cnt].nxt=head[cu];
        head[cu]=cnt++;
    }
    
    void Tarjan(int u,int fa){
        int son=0;
        vis[u]=1;
        dfn[u]=low[u]=++k;
        for(int i=head[u];i!=-1;i=edge[i].nxt){
            int v=edge[i].to;
            if(vis[v]==1 && v!=fa)
                low[u]=min(low[u],dfn[v]);
            if(vis[v]==0){
                Tarjan(v,u);
                son++;
                low[u]=min(low[u],low[v]);
                if((u==root && son>1) || (u!=root && dfn[u]<=low[v]))
                    cut[u]=1;
            }
        }
        vis[u]=2;
    }
    
    int main(){
    
        //freopen("input.txt","r",stdin);
    
        while(~scanf("%d",&n) && n){
            memset(head,-1,sizeof(head));
            memset(dfn,0,sizeof(dfn));
            memset(low,0,sizeof(low));
            memset(vis,0,sizeof(vis));
            memset(cut,0,sizeof(cut));
            cnt=0;
            int u,v;
            while(scanf("%d",&u) && u){
                while(getchar()!='\n'){
                    scanf("%d",&v);
                    addedge(u,v);
                    addedge(v,u);
                }
            }
            root=1;
            Tarjan(root,-1);
            int ans=0;
            for(int i=1;i<=n;i++)
                if(cut[i])
                    ans++;
            printf("%d\n",ans);
        }
        return 0;
    }
    #include <iostream>
    #include <string.h>
    #include <stdio.h>
    #define M 110
    using namespace std;
    int dep[M],low[M],head[M];
    bool cut[M];
    int e,n,rt,son;
    struct E
    {
        int to,nxt;
    }edge[M*M];
    
    void addedge (int cu,int cv)
    {
        edge[e].to = cv;
        edge[e].nxt = head[cu];
        head[cu] = e ++;
    }
    
    int min (int a,int b)
    {
        return a > b ? b : a;
    }
    void dfs (int cnt,int u)
    {
        dep[u] = low[u] = cnt;
        for (int i = head[u];i != -1;i = edge[i].nxt)
        {
            int v = edge[i].to;
            if (!dep[v])
            {
                dfs (cnt + 1,v);
                if (u == rt)
                    son ++;
                else
                {
                    low[u] = min (low[u],low[v]);
                    if (dep[u] <= low[v])
                        cut[u] = true;
                }
            }
            else
                low[u] = min (low[u],dep[v]);
        }
    }
    int main ()
    {
        int u,v;
        while (cin >> n&&n)
        {
            memset (dep,0,sizeof(dep));
            memset (low,0,sizeof(low));
            memset (cut,false,sizeof(cut));
            memset (head,0xFF,sizeof (head));
            e = 0;
            while (cin >> u&&u)
                while (getchar()!= '\n')
                {
                    cin >> v;
                    addedge (u,v);
                    addedge (v,u);
                }
            rt = 1;son = 0;
            dfs (1,rt);
            int ans = 0;
            if (son > 1)
                ans ++;
            for (int i = 1;i <= n;i ++)
                if (cut[i])
                    ans ++;
            cout <<ans<<endl;
        }
        return 0;
    }
  • 相关阅读:
    电容的用法:去耦、旁路、滤波等
    成为出色工程师的十大要素
    常用三极管的区别 9012 9013 9014 9015 8550 8050
    照明的几个光学概念
    PCB元件封装
    为什么诈骗短信看上去那么弱智
    摄像·镜头
    LED家居照明
    光色的应用与照度范围
    PowerPCB(PADS)常见问题全集
  • 原文地址:https://www.cnblogs.com/jackge/p/3053711.html
Copyright © 2011-2022 走看看