zoukankan      html  css  js  c++  java
  • HDU 2120 Ice_cream's world I

    Ice_cream's world I

    Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 355    Accepted Submission(s): 181


    Problem Description
    ice_cream's world is a rich country, it has many fertile lands. Today, the queen of ice_cream wants award land to diligent ACMers. So there are some watchtowers are set up, and wall between watchtowers be build, in order to partition the ice_cream’s world. But how many ACMers at most can be awarded by the queen is a big problem. One wall-surrounded land must be given to only one ACMer and no walls are crossed, if you can help the queen solve this problem, you will be get a land.
     
    Input
    In the case, first two integers N, M (N<=1000, M<=10000) is represent the number of watchtower and the number of wall. The watchtower numbered from 0 to N-1. Next following M lines, every line contain two integers A, B mean between A and B has a wall(A and B are distinct). Terminate by end of file.
     
    Output
    Output the maximum number of ACMers who will be awarded.
    One answer one line.
     
    Sample Input
    8 10 0 1 1 2 1 3 2 4 3 4 0 5 5 6 6 7 3 6 4 7
     
    Sample Output
    3
     
    Author
    Wiskey
     
    Source
     
    Recommend
    威士忌

    题意没看太清楚,,,GOD

    并查集的应用,用来查找被分割的区域个数。

    即当两个节点值相同时说明已经为了一个圈,否则不可能,此时区域个数加1.

    #include<iostream>
    #include<cstdio>
    #include<cstring>
    
    using namespace std;
    
    const int maxn=1010;
    
    int n,m;
    int father[maxn];
    
    void makeSet(){
        for(int i=0;i<n;i++){
            father[i]=i;
        }
    }
    
    int findSet(int x){
        if(x!=father[x]){
            father[x]=findSet(father[x]);
        }
        return father[x];
    }
    
    int main(){
    
        //freopen("input.txt","r",stdin);
    
        while(~scanf("%d%d",&n,&m)){
            makeSet();
            int ans=0;
            int a,b;
            while(m--){
                scanf("%d%d",&a,&b);
                int fx=findSet(a);
                int fy=findSet(b);
                if(fx==fy)
                    ans++;
                else
                    father[fx]=fy;
            }
            printf("%d\n",ans);
        }
        return 0;
    }
  • 相关阅读:
    概率统计(DP)
    iOS中几种定时器
    微信开发笔记——微信网页登录授权,获取用户信息
    swift中通知的使用
    Swift的基础,操作符,字符串和集合类型
    NSNotificationCenter
    IOS中通知中心(NSNotificationCenter)的使用总结
    Swift观察者模式
    swift中通知的使用
    Swift
  • 原文地址:https://www.cnblogs.com/jackge/p/3097376.html
Copyright © 2011-2022 走看看