zoukankan      html  css  js  c++  java
  • HDU1004——Let the Balloon Rise

    Problem Description
    Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

    This year, they decide to leave this lovely job to you.
     

    Input
    Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

    A test case with N = 0 terminates the input and this test case is not to be processed.
     

    Output
    For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.
     

    Sample Input
    5 green red blue red red 3 pink orange pink 0
     

    Sample Output
    red pink
     
    分析:map第二弹~
    #include<iostream>
    #include<string.h>
    #include<stdio.h>
    #include<ctype.h>
    #include<algorithm>
    #include<stack>
    #include<queue>
    #include<set>
    #include<math.h>
    #include<vector>
    #include<map>
    using namespace std;
    int main()
    {
        int n;
        string color,s;
        map<string,int>Balloon;
        while(scanf("%d",&n)&&(n!=0))
        {
            Balloon.clear();
            for(int i=0;i<n;i++)
            {
                cin>>color;
                Balloon[color]++;
            }
            int max=-1;
            map<string,int>::iterator p;
            for(p=Balloon.begin();p!=Balloon.end();p++)
            {
                if((*p).second>max)
                {
                    max=(*p).second;
                    s=(*p).first;
                }
            }
            cout<<s<<endl;
        }
        return 0;
    }
    

     
  • 相关阅读:
    web服务器iis安全设置
    Log explorer for sql server
    C#将image中的显示的图片转换成二进制
    .Net平台开发的技术规范与实践精华总结
    .net面试题整理
    Javascript 刷新框架及页面的方法总集
    WEB程序代码优化入手的几方面
    用js控制网页播放器
    SQL Server2000中死锁经验总结
    专家谈CSS设计
  • 原文地址:https://www.cnblogs.com/james1207/p/3258124.html
Copyright © 2011-2022 走看看