zoukankan      html  css  js  c++  java
  • POJ2378:Tree Cutting(DFS) java程序员

    Tree Cutting
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 3022   Accepted: 1767

    Description

    After Farmer John realized that Bessie had installed a "tree-shaped" network among his N (1 <= N <= 10,000) barns at an incredible cost, he sued Bessie to mitigate his losses. 

    Bessie, feeling vindictive, decided to sabotage Farmer John's network by cutting power to one of the barns (thereby disrupting all the connections involving that barn). When Bessie does this, it breaks the network into smaller pieces, each of which retains full connectivity within itself. In order to be as disruptive as possible, Bessie wants to make sure that each of these pieces connects together no more than half the barns on FJ. 

    Please help Bessie determine all of the barns that would be suitable to disconnect.

    Input

    * Line 1: A single integer, N. The barns are numbered 1..N. 

    * Lines 2..N: Each line contains two integers X and Y and represents a connection between barns X and Y.

    Output

    * Lines 1..?: Each line contains a single integer, the number (from 1..N) of a barn whose removal splits the network into pieces each having at most half the original number of barns. Output the barns in increasing numerical order. If there are no suitable barns, the output should be a single line containing the word "NONE".

    Sample Input

    10
    1 2
    2 3
    3 4
    4 5
    6 7
    7 8
    8 9
    9 10
    3 8

    Sample Output

    3
    8

    Hint

    INPUT DETAILS: 

    The set of connections in the input describes a "tree": it connects all the barns together and contains no cycles. 

    OUTPUT DETAILS: 

    If barn 3 or barn 8 is removed, then the remaining network will have one piece consisting of 5 barns and two pieces containing 2 barns. If any other barn is removed then at least one of the remaining pieces has size at least 6 (which is more than half of the original number of barns, 5).

    Source

    MYCode:
    #include<iostream>
    #include<cstring>
    #include<cstdio>
    #include<vector>
    using namespace std;
    #define MAX 10010
    bool vis[MAX];
    vector<int> list[MAX];
    int sum[MAX];
    struct edge
    {
        int v;
        int next;
    }E[2*MAX];
    int head[MAX];
    bool sign[MAX];
    int num;
    int n;
    int ans;
    void init()
    {
        memset(head,-1,sizeof(head));
        memset(vis,0,sizeof(vis));
        memset(sign,false,sizeof(sign));
        memset(sum,0,sizeof(sum));
        num=0;
        ans=0;
        int i;
        for(i=1;i<=n;i++)
        list[i].clear();
    }
    void add(int s,int t)
    {
        E[num].v=t;
        E[num].next=head[s];
        head[s]=num++;
    }
    void dfs(int cur)
    {
        vis[cur]=true;
        int i;
        bool flag=false;
        for(i=head[cur];i!=-1;i=E[i].next)
        {
            int v=E[i].v;
            if(vis[v])
            continue;
            dfs(v);
            sum[cur]+=sum[v];
            if(sum[v]>n/2)
            {
                flag=true;
            }
        }
        sum[cur]++;
        int add=n-sum[cur];
        if(add>n/2)
        flag=true;
        if(flag==true)
        {
            sign[cur]=true;
        }
    }
    int main()
    {
        while(scanf("%d",&n)!=EOF)
        {
            int i;
            init();
            int s,t;
            for(i=1;i<=n-1;i++)
            {
                scanf("%d%d",&s,&t);
                add(s,t);
                add(t,s);
            }
            dfs(1);
            bool find=false;
            for(i=1;i<=n;i++)
            {
                if(!sign[i])
                {
                    find=true;
                    printf("%d\n",i);
                }
            }
            if(find==false)
            {
                printf("NONE\n");
            }
        }
    }
    //
    判断去掉一个节点后各个子树的大小,任选一个节点作为root,DFS,对于当前节点,去掉它之后,剩下的子树是以其所有子节点为根的树,还有从整棵树中删掉以当前节点为根的子树后剩下的树.
  • 相关阅读:
    如何在ASP.NET中使用div弹出窗口
    How to avoid error "LNK2001 unresolved external" by using DEFINE_GUID
    一个JavaScript实现的幻灯片程序分析
    Systems Thinking in Project Management
    CSS
    How To Clear Floats Without Structural Markup
    Public Symbols and Private Symbols
    DOM and CSS positioning
    JavaScript对象模型执行模型
    JavaScript 操作图片
  • 原文地址:https://www.cnblogs.com/java20130725/p/3215883.html
Copyright © 2011-2022 走看看