zoukankan      html  css  js  c++  java
  • POJ 1035 Spell checker【字符串处理】

    Description

    You, as a member of a development team for a new spell checking program, are to write a module that will check the correctness of given words using a known dictionary of all correct words in all their forms. 
    If the word is absent in the dictionary then it can be replaced by correct words (from the dictionary) that can be obtained by one of the following operations: 
    ?deleting of one letter from the word; 
    ?replacing of one letter in the word with an arbitrary letter; 
    ?inserting of one arbitrary letter into the word. 
    Your task is to write the program that will find all possible replacements from the dictionary for every given word. 

    Input

    The first part of the input file contains all words from the dictionary. Each word occupies its own line. This part is finished by the single character '#' on a separate line. All words are different. There will be at most 10000 words in the dictionary. 
    The next part of the file contains all words that are to be checked. Each word occupies its own line. This part is also finished by the single character '#' on a separate line. There will be at most 50 words that are to be checked. 
    All words in the input file (words from the dictionary and words to be checked) consist only of small alphabetic characters and each one contains 15 characters at most. 

    Output

    Write to the output file exactly one line for every checked word in the order of their appearance in the second part of the input file. If the word is correct (i.e. it exists in the dictionary) write the message: " is correct". If the word is not correct then write this word first, then write the character ':' (colon), and after a single space write all its possible replacements, separated by spaces. The replacements should be written in the order of their appearance in the dictionary (in the first part of the input file). If there are no replacements for this word then the line feed should immediately follow the colon.

    Sample Input

    i
    is
    has
    have
    be
    my
    more
    contest
    me
    too
    if
    award
    #
    me
    aware
    m
    contest
    hav
    oo
    or
    i
    fi
    mre
    #

    Sample Output

    me is correct
    aware: award
    m: i my me
    contest is correct
    hav: has have
    oo: too
    or:
    i is correct
    fi: i
    mre: more me

    题意:给出所谓的字典,然后再给出要查找的单词,如果单词存在于字典中输出...is correct;否则输出与查的单词有一个字母不同,可以多一个字母,少一个字母的单词。
    代码如下:
    View Code
    #include<stdio.h>
    #include<string.h>
    char ch[10002][20], son[30]; 
    int main()
    {
        int i, j, t, jj;
        for(t=0; ; t++)
        {
            scanf("%s", ch[t]);
            if(ch[t][0]=='#')    break;
        }
        while(1)
        {
             scanf("%s",  son);
             if(son[0]=='#')    break;
             int flag=0, len1=strlen(son);
             int r1[20], r2[20], r3[20], t1, t2, t3; 
             for(i=0; i<t; i++)
                 if(strcmp(son, ch[i])==0)    {printf("%s is correct", son); break;}
              if(i==t)
             {
                      printf("%s:",son);
                 for(i=0; i<t; i++)
                 {
                        int len=strlen(ch[i]);
                        int ll=strlen(son);
                     if(len==ll)
                     {     
                          int num=0; 
                           for(j=0; j<len; j++)
                              if(ch[i][j]!=son[j])
                                  num++;
                          if(num==1)     printf(" %s", ch[i]);
                     }
                     if(len-ll==1) //多一个字符 
                     {
                          int num=0; 
                          for(jj=0,j=0; j<len; )
                            {
                             if(ch[i][j]!=son[jj])
                                  num++, j++;
                             else
                                 j++, jj++;
                         }
                         if(num==1)
                             printf(" %s", ch[i]);
                      }
                      if(ll-len==1)
                      {
                            int num=0;
                          for(j=0, jj=0; jj<ll; )
                          {
                                if(ch[i][j]!=son[jj])
                                 num++, jj++;
                              else
                                   j++, jj++;
                          }
                          if(num==1)
                             printf(" %s", ch[i]);
                       }
                   }
              }
              printf("\n");
          } 
    }
  • 相关阅读:
    520了,用32做个简单的小程序
    年轻就该多尝试,教你20小时Get一项新技能
    自定义注解!绝对是程序员装逼的利器!!
    vs2015添加ActiveX Control Test Container工具(转载)
    编译MapWinGis
    C#遍历集合与移除元素的方法
    c#winform程序,修改MessageBox提示框中按钮的文本
    java程序员面试答题技巧
    什么是DOM
    uml类关系
  • 原文地址:https://www.cnblogs.com/Hilda/p/2622423.html
Copyright © 2011-2022 走看看