zoukankan      html  css  js  c++  java
  • uva100—— The 3n + 1 problem

    原题:

    Background

    Problems in Computer Science are often classified as belonging to a certain class of problems (e.g., NP, Unsolvable, Recursive).  In this problem you will be analyzing a property of an algorithm whose classification is not known for all possible inputs.

    The Problem

    Consider the following algorithm:

     
    		1. 		 input n
    

    2. print n

    3. if n = 1 then STOP

    4. if n is odd then tex2html_wrap_inline44

    5. else tex2html_wrap_inline46

    6. GOTO 2

    Given the input 22, the following sequence of numbers will be printed 22 11 34 17 52 26 13 40 20 10 5 16 8 4 2 1

    It is conjectured that the algorithm above will terminate (when a 1 is printed) for any integral input value.  Despite the simplicity of the algorithm, it is unknown whether this conjecture is true.  It has been verified, however, for all integers n such that 0 < n < 1,000,000 (and, in fact, for many more numbers than this.)

    Given an input n, it is possible to determine the number of numbers printed (including the 1).  For a given n this is called the cycle-length of n.  In the example above, the cycle length of 22 is 16.

    For any two numbers i and j you are to determine the maximum cycle length over all numbers between i and j.

    The Input

    The input will consist of a series of pairs of integers i and j, one pair of integers per line.  All integers will be less than 1,000,000 and greater than 0.

    You should process all pairs of integers and for each pair determine the maximum cycle length over all integers between and including i and j.

    You can assume that no operation overflows a 32-bit integer.

    The Output

    For each pair of input integers i and j you should output i, j, and the maximum cycle length for integers between and including i and j.  These three numbers should be separated by at least one space with all three numbers on one line and with one line of output for each line of input.  The integers i and j must appear in the output in the same order in which they appeared in the input and should be followed by the maximum cycle length (on the same line).

     

    Sample Input

    1 10
    100 200
    201 210
    900 1000
    

    Sample Output

    1 10 20
    100 200 125
    201 210 89
    900 1000 174
    

    分析:

    本打算找到水题练练手,这题竟然卡了,直接卡的我蛋疼,尼玛,尼玛、尼玛~!!

    #include<stdio.h>
    #include<string.h>
    int t;
    int f(int x)
    {
        t=1;
        while(x!=1)
        {
            if(x%2==0)
                x=x/2;
            else x=3*x+1;
            t++;
        }
        return t;
    }
    int main()
    {
        int m,n,p;
        int a[9999];
        while(scanf("%d%d",&m,&n)!=EOF)
        {
            if(m>n)
            {
                int t;
                t=m;
                m=n;
                n=t;
            }
            memset(a,0,sizeof(a));
            for(int i=m; i<=n; i++)
            {
               f(i);
               a[i]=t;
            }
            int max=-1;
            for(int j=m;j<=n;j++)
            {
                if(a[j]>max)
                {
                    max=a[j];
                }
            }
            printf("%d %d %d\n",m,n,max);
        }
        return 0;
    }
    


     

    尼玛,尼玛、尼玛直接runtime error!

    为什么不过呢?亮点自寻~

    我总结了,数组最大能开到99999;;;;;

    尼玛尼玛,直接搞得我蛋疼,蛋疼啊啊~

    后来参考屌丝们的源码,终于~~~~            尼玛

    #include<stdio.h>
    int t;
    int f(int x)
    {
        t=1;
        while(x!=1)
        {
            if(x%2==0)
                x=x/2;
            else x=3*x+1;
            t++;
        }
        return t;
    }
    int main()
    {
        int m,n,begin,end;
        while(scanf("%d%d",&m,&n)!=EOF)
        {
            if(m>n)
            {
               begin=n;
               end=m;
            }
            else
            {
                begin=m;
                end=n;
            }
                int max=-1;
                for(int i=begin; i<=end; i++)
                {
                    if(max<f(i))
                        max=f(i);
                }
                printf("%d %d %d\n",m,n,max);
        }
        return 0;
    }
    


     

  • 相关阅读:
    w3c盒子模型与ie盒子模型
    前端入门
    连接数据库好用工具
    前端开发工具
    刚发现的取色工具
    使用val()另一个妙用------选中select/checkbox/radio的值
    z-index的妙用
    react生命周期函数
    react中虚拟dom的diff算法
    React中的虚拟DOM
  • 原文地址:https://www.cnblogs.com/javawebsoa/p/3106602.html
Copyright © 2011-2022 走看看