zoukankan      html  css  js  c++  java
  • poj 2828 Buy Tickets 树状数组

    Buy Tickets

    Description

    Railway tickets were difficult to buy around the Lunar New Year in China, so we must get up early and join a long queue…

    The Lunar New Year was approaching, but unluckily the Little Cat still had schedules going here and there. Now, he had to travel by train to Mianyang, Sichuan Province for the winter camp selection of the national team of Olympiad in Informatics.

    It was one o’clock a.m. and dark outside. Chill wind from the northwest did not scare off the people in the queue. The cold night gave the Little Cat a shiver. Why not find a problem to think about? That was none the less better than freezing to death!

    People kept jumping the queue. Since it was too dark around, such moves would not be discovered even by the people adjacent to the queue-jumpers. “If every person in the queue is assigned an integral value and all the information about those who have jumped the queue and where they stand after queue-jumping is given, can I find out the final order of people in the queue?” Thought the Little Cat.

    Input

    There will be several test cases in the input. Each test case consists of N + 1 lines where N (1 ≤ N ≤ 200,000) is given in the first line of the test case. The next N lines contain the pairs of values Posi and Valiin the increasing order of i (1 ≤ i ≤ N). For each i, the ranges and meanings of Posi and Vali are as follows:

    • Posi ∈ [0, i − 1] — The i-th person came to the queue and stood right behind the Posi-th person in the queue. The booking office was considered the 0th person and the person at the front of the queue was considered the first person in the queue.
    • Vali ∈ [0, 32767] — The i-th person was assigned the value Vali.

    There no blank lines between test cases. Proceed to the end of input.

    Output

    For each test cases, output a single line of space-separated integers which are the values of people in the order they stand in the queue.

    Sample Input

    4
    0 77
    1 51
    1 33
    2 69
    4
    0 20523
    1 19243
    1 3890
    0 31492

    Sample Output

    77 33 69 51
    31492 20523 3890 19243

    Hint

    The figure below shows how the Little Cat found out the final order of people in the queue described in the first test case of the sample input.

    Source

    思路:从后往前排,每次的数位置为这个队列剩余位置的第pos[i]个的位置;我二分区间找;
    #include<iostream>
    #include<cstdio>
    #include<cmath>
    #include<string>
    #include<queue>
    #include<algorithm>
    #include<stack>
    #include<cstring>
    #include<vector>
    #include<list>
    #include<set>
    #include<map>
    using namespace std;
    #define ll long long
    //#define mod 1000000007
    #define pi (4*atan(1.0))
    const int N=4e5+10,M=1e6+10,inf=1e9+10;
    int a[M];
    int lowbit(int x)
    {
        return x&-x;
    }
    void update(int x,int change,int n)
    {
        while(x<=n)
        {
            a[x]+=change;
            x+=lowbit(x);
        }
    }
    int query(int x)
    {
        int sum=0;
        while(x)
        {
            sum+=a[x];
            x-=lowbit(x);
        }
        return sum;
    }
    int pos[N];
    int val[N];
    int check(int x,int len)
    {
        int st=1;
        int en=len;
        while(st<en)
        {
            int mid=(st+en)>>1;
            int gg=query(mid);
            if(gg<x)
            st=mid+1;
            else
            en=mid;
        }
        return st;
    }
    int ans[N];
    int main()
    {
        int x,y,z,i,t;
        while(~scanf("%d",&x))
        {
            for(i=1;i<=x;i++)
            update(i,1,x);
            for(i=0;i<x;i++)
            {
               scanf("%d%d",&pos[i],&val[i]);
               pos[i]++;
            }
            for(i=x-1;i>=0;i--)
            {
                int poss=check(pos[i],x);
                ans[poss]=val[i];
                update(poss,-1,x);
            }
            for(i=1;i<=x;i++)
            printf("%d%c",ans[i],(i==x)?'
    ':' ');
        }
        return 0;
    }
  • 相关阅读:
    Oracle配置手册
    Vim配置手册
    高斯消元
    dp专场的蒟蒻题解
    mac 软件意外退出
    spring security整体流程
    服务启动shell脚本
    nohup 启动命令
    linux service脚本
    docker 安装prometheus和grafna
  • 原文地址:https://www.cnblogs.com/jhz033/p/5576611.html
Copyright © 2011-2022 走看看